Joel koblich

Tower S08LL64 Boards Won't Communicate with Three Different PCs!

Discussion created by Joel koblich on Mar 15, 2010
Latest reply on Apr 30, 2010 by Styger

What we've got here is a basic failure to communicate.  Hopefully someone out there can help.  Is anybody aware of anything that could cause non-communication between a tower S08LL64 board and 3 different PCs? 

  • Just got two brand new S08LL64 tower kits a few weeks ago.
  • Either S08LL64 board will light up and run demo properly when PC is USB-connected directly to S08LL64 board NOT plugged into elevator boards (as outlined in the Quick Start Guide).  Yes, driver seems to configure just fine.
  • Either S08LL64 will light up and run demo properly when USB-connected directly to S08LL64 board properly plugged into elevator boards (primary card-edge connector attached to functional tower connector).
  • CodeWarrior Quick Start project on DVD would not compile, so Freescale Tech Support had me download the latest version from their website.  That newer version builds just fine, but when I try to download and debug, HiWave debugger says there is no communication with the hardware.  Says "CHECK CABLE", but cable is fine.
  • The Accelerometer demo project also will not download or debug.  Same error message.
  • In debugger, Connect option yields same error message.
  • The above are all true for each of 3 different PCs, one running Win7 and two running XP.  Only one of the PCs has ever had CW previously installed, but the other two PCs have fresh CW installs.

I'm not new to Freescale products and I've never had this much trouble with setting up any of their other demo boards in the past, so I hope I'm just missing something simple.  However, the DVD-provided Quick Start CW project would not build, so maybe the docs also contain errors, like maybe the jumper settings are wrong?  Or maybe CW 6.3 is the problem? 

 

Thanks for any advice and suggestions. 

 

Joel

Outcomes