AnsweredAssumed Answered

Open Source BDM and S08QG8

Question asked by Magnus Lundell on Mar 25, 2006
Latest reply on Jan 9, 2008 by Guest
Hello, I have built an open source bdm-pod and I'm not sure if it works or if I just can't use it and CW.
I'm new to CW, have only used PE ,HC08 and assembler before.
I have have done connections as outlined in the BDM connection guide  in the 9S08QG datasheet.
When I type"set gdi" in the command window sometimes this happens:
No Link To Target
in>set gdi
Loading Target ...
SETCOMM DRIVER NOPROTOCOL NOPERIODICAL "opensourcebdm_gdi_s08_v3.dll"
SETCOMM COMPORT NONE
SETCOMM DRIVER NOPROTOCOL NOPERIODICAL "opensourcebdm_gdi_s08_v3.dll"
SETCOMM COMPORT NONE
Target Speed Change Detected - New Speed 16.70 MHz
Target Speed Change Detected - New Speed 16.70 MHz
Startup command file does not exist.
Target Speed Change Detected - New Speed 17.26 MHz
Target Ready
Target Speed Change Detected - New Speed 17.26 MHz
Target Speed Change Detected - New Speed 16.70 MHz
Target Speed Change Detected - New Speed 26.03 MHz
in>
Why does the speed change?
On the status bar It says "NOT_CONNECTED_SECURED" and  "Target ready"
 
Another thing is that the connection "Open Source BDM" is not available in the list of connections from within IDE. I have to start the debugger with full "chip simulation" or "PE multilink/CyclonePro" and then use the set gdi command.
When I load the executable I get error messages. Should I load the .abs file?
I know have missed something elementary...
Can anybody help me?
 
Thanks,
 
Sungam

Outcomes