AnsweredAssumed Answered

Invalid project file

Question asked by Cab Jones on May 24, 2012
Latest reply on May 24, 2012 by Erich Styger

CW 10.2, HC9S08LG32 Win32x64

 

This is a hard error for me--happens every time even after a fresh CW install.  But I don't see any complaints. I must not understand how to import a project, even when CW is leading me by the nose.

 

From the Welcome screen I choose [Project Importer].  I browse for the project and choose one I have been recently using.  I open it and choose .project (It doesn't give me a clue what kind of file to pick, but it only takes .project or .cproject). If I choose either one I get [Invalid project file].  Tried on more than one project.

  • Maybe that is the reason for my recent problems with "Error importing Task" and "NullPointerException."
  • I inherited the project and received it as a zip-file.  After unzipping, CW couldn't see it no matter what I set my workspace to.  And if I tried to "import" it I always got "invalid project file.
  • So I built a bare-bones project then copied the source files into the Sources folder using Windows copy-and-paste.  The eclipse tutorial said I could do this.  That project hasbeen working just fine.  Until I recently copied it and started using the copy--and got all kinds of' "Error importing task" and NPE's and  MC9S08LG32.xml getting truncated to 0 bytes.

  • So I want to move it out of my workspace and away from my .metadata file.  This should be a good project file, I know the history, but it won't import.  Looks like I'll have to start with just the sources again.

Outcomes