AnsweredAssumed Answered

serial line of a TWR60 is not sending data if using processor expert

Question asked by Markus Krug on May 16, 2012
Latest reply on May 19, 2012 by Erich Styger

Hello,

 

since a couple of days I work with the TWR60 to get used to the K60µC.

 

I tried out some of the examples. One of them is described in chapter 3 in:

http://cache.freescale.com/files/soft_dev_tools/doc/user_guide/PEXDRVGETSTARTEDUG.pdf

 

I do this to get used to the ProcessorExpert. In this example a GPIO and the serial line is used.

 

So far the blinking diode works. But the serial line does not. It simply did not send any data. To find out more about the problem I wrote the return value of AS1_SendBlock() in a variable to see how many characters the software thinks it has send. Interestingly I always got back 8 - however the string "HelloWorld" consist of 11 (including \n).

Anyone an idea what is going wrong here ? Does one have a simple working project that uses the serial line that I can copy as a clean start point ?

 

So far I have not tried the same thing without ProcessorExpert. My intention was to get rid of the low-level software configuration and use that tool for it.

 

Best Regards

Markus

 

 

Outcomes