AnsweredAssumed Answered

KwikStik and USB Stack 3.2

Question asked by Mike Sorenson on May 12, 2012
Latest reply on May 12, 2012 by Mike Sorenson

First off, has anyone been able to run any version of a Freescale USB Stack on a KwikStik?  Here are my challenges and where I am at today.

 

I am running Windows 7-64bit, CW 10.2, USB Stack 3.2.

Trying to import the Virtual Com project from the USB Stack results in an immediate error, that I believe stems from permissions on being able to access or transfer files:

 

Error processing changed links in project description file.
Could not write file: C:\Program Files (x86)\Freescale USB Stack v3.2.0\Source\Device\app\cdc\cw10\kinetis_k40\.project.
C:\Program Files (x86)\Freescale USB Stack

....

 

I tried changing my default workspace to a more generic c:\workspace and that didn't help at all.

 

Next I tried running in XPmode and installed CW10.2 and USB Stack 3.2

I was able to import the project, but then the code had problems.  With some help I was able to comment out usb_bsp.h and change  MCG_S_OSCINIT0_MASK to MCG_S_OSCINIT_MASK.  At this point I can compile the project, but now when I try to debug and load the code on my KwikStick I get another error:

Error creating session: The remote system chosen in the Launch Configuration Main Tab is unknown.

 

Does anyone know a way to make this work?

 

 

Outcomes