Angelo Quattrociocchi

Problem with AN4368 USB bootloader on MCF52259

Discussion created by Angelo Quattrociocchi on Feb 26, 2012
Latest reply on Feb 29, 2012 by Angelo Quattrociocchi

I'm having trouble getting the USB host bootloader working following AN4368 on an MCF52259 processor. I tried using the project in the 'Codewarrior' folder for CW7.2, and also the 'CW10' project, but could get neither to work.

The CW 7.2 project compiled OK, however the CW10 project wouldn't compile until I changed exceptions_cfv2_c.obj(.vectortable) to exceptions_cfv2.obj(.vectortable) in the LCF file. It also didn't seem to open the .launch file so I created a new one but may have missed something. It also reported issues with certain paths, so I don't feel that project was set up properly.

 

Even once compiled, neither version executes. The CW7.2 version halts at the first instruction in _startup(), move.w #0x2700,sr. In CW10.1 it halts at jmp (a1) in Switch_mode().

 

I tried both of these projects on the MCF52259 tower and also another 52259-based custom board, with similar results.

 

I would also try to load the pre-compiled code as directed in the app note, except they are not included in the archive.

 

I had couple of other questions about this project - as I understand it this is a self-contained project and it doesn't rely on the MQX bsp or psp projects, correct? Also, it seems that to enable printf support I need to change #define NO_PRINTF 0 in exceptions_cvf2.c, and add #define CONSOLE_IO_SUPPORT 1 in exceptions_cvf2.h. Are there other things I need to be aware of?

Has anyone managed to get this bootloader working on an MCF52259 platform?

Thanks for your help.

Outcomes