Chris LaRocque

Two identical projects, one compiles and runs the other does not

Discussion created by Chris LaRocque on Feb 13, 2012
Latest reply on Feb 14, 2012 by Chris LaRocque

Hello

MY PC:

AMD Phenom Quad Core 955
16 GB Memory
SATA - Multiple Drives
NVidia graphics with NVidia Proprietary Drivers
Gigabyte MB

Opensuse 11.4 x86-64
KDE

targeting Power QUICC Pro

I have the MPC8308RDB; Linux

I installed ltib-mpc8308erdb-20100413, rebuilt the Kernel, pushed it down to the board and booted from ram.

Installed CW release Linux 8.8 unlicensed, compiled a hello world cpp project, configured for apptrk debug over ethernet, and booted the app. Debugger and code worked.

Then I created a second app;

Long story short, although my first app compiles and runs in the debugger on the target, no other app I've created will compile.

The error is "error trying to exec 'cc1plus': execvp: No such file or directory"

 

If my project is c++ then the error is as above, if its a c project then exchange cc1 for cc1plus in the same message.

I've verified the presence of the files and re-installed several times; the results are consistent. Only my first app will compile.

I even tried to re-create the first app; New project, New file, copy the code from file 1 to file 2 and still no dice.

I'm at a loss.

Help?

Attached are the two projects; test will compile and run and test2 will not.

Thanks for the help in advance.

Regards

Chris LaRocque
Measurement Specialties

chris<dot>larocque<at>meas<dash>spec<dot>com

Outcomes