Andreas Herke

Bug found in CW 2.9 for MPC55xx/56xx

Discussion created by Andreas Herke on Jan 29, 2012
Latest reply on Jan 30, 2012 by Tom Thompson

Hi guys,

 

i've only checked on Google for a minute if there was a bug report similar to this one, but found none so figured i'm gonna post this here.

 

I installed said CW yesterday on my old laptop since my main PC broke down during project work. That laptop has a broken CMOS battery and as such, the date and all other BIOS data is reset when the battery is empty and there is no grid power supply connected.

So CW was working fine until that reset, and even then it was working perfectly fine when my BIOS default date was set to June 2004. I realized it after some minutes of working in CW again, and decided to restart the laptop in order to set up the date in the BIOS correctly.

When i set in for January 2012 and booted up again, CW would throw a Microsoft Error Dialog window (.. has encountered a problem) and close down, regardless if i started from a project file or the empty IDE.

I reset the date in the BIOS for 2004 and it worked again.

I tried another use case: With 2004 date set in BIOS, i opened CW without errors. I then set the date back to 2012 and CW would still work, but not upon re-opening. I now have to set the date back to 2004 each time i start CW up ^^ There you go..

And btw i tried un-/re-/installing it again in every variant, even with manually deleting corresponding registry entries and files and stuff like that, that is not completely removed upon uninstall. But nothing helped except the above mentioned date workaround.

 

Let me know what you think

Andreas Herke

 

edit: This is on a 32-bit WinXP SP3.

Outcomes