AnsweredAssumed Answered

New MQX3.8 project with CW10.2 and TWRK60

Question asked by Radek Tesar on Jan 25, 2012
Latest reply on Feb 1, 2012 by Petr Uhlir

Hi,

 

I try create a new project in CW10.2, with MQX3.8 and RTCS support. Target is Tower K60N512. I create new workspace, then File -> New -> MQX3.8 Project -> Project Name (SemProj) -> Kinetis Eval Board -> TWRK60N512 -> New Application -> Add RTCS support -> Basic Application -> DHCP -> next -> next -> Open Source Jtag -> finish. When I try to build it, I got 3 errors and 9 warnings. I read, that K60 hasnt enought Ram to create MQX project with RTCS in Ram, so I changed active build configuration in internal flash debug, but still get 1 error and 9 warnings (see attachment). I follow FSL_MQX_getting_started.pdf, but result is still the same.

 

I also try to complette FSL_MQX_in_CW_10_x.pdf (from MQX3.8/doc/tools directory), and can create PE working set, build, debug and run PE DEMO project. But when I try to throught page 128 (MQX and PE: NEW LDD Driver), I can add AD1:ADC_LDD, configure it (well, there is a bit different conversion time settings, but its no problem to me) and add code as required. But when I try to build project according to presentation, it failed (see second attachement). It seems not know AD1_TresultData (this is first error with ';' expected). Second Error is at line AD1_Init(). Third error I dont know came from, but last two errors will be sort out when I find solution for the first one.

 

Can anybody help Me? I suppose I make some big mistake with set up project, which lead in this errors, but it isnt obvious to me...thanks..:smileywink:

Outcomes