AnsweredAssumed Answered

CodeWarrior 8- & 16-bit tools: HCS08 Problem with Hiwave hanging when PE Tool invoked

Question asked by Marc Paquette Employee on Jan 27, 2006
To help you find solutions to problems that have already been solved, we have posted this message. It contains an entire topic ported from a separate forum. The original message and all replies are in this single message.
 

 
Posted: Nov 03, 2005 - 02:38 PM   
 
I have a Freescale 13192 SARD board (9S08GT60) connected to a P&E USB Multilink Interface (USB-ML-12 which supports the HCS08 family) driven by an SE license copy.
 
I can compile and start the Hiwave tool in simulator mode but as soon as I change to my target using the P&E tool Hiwave hangs indefinitely. To some degree I know the tool is OK as the blue light comes on and the USB driver in my Win system hardware indicates all is well.
 
Is there anyway to troubleshoot this problem? I have no idea why it hangs - it just hangs. I've tried invoking Hiwave on it's own but again, as soon as I switch to my target programmer/debugger from simulator mode the software hangs. If anyone can pass along information I would be very grateful. TIA. 
 
 
Posted: Nov 03, 2005 - 03:03 PM   
 
I should also note the I am running CW08 V3.1 and have updated with USB2 SP. 
 
 
Posted: Nov 04, 2005 - 10:19 PM   
 
Have you tried running the PE Micro driver test to see if all the usb drivers are in the right place:
Things should work if it says everything is ok. I ended up running the PE Micro driver installer rather than the metrowerks installer for the usb drivers.
jon

 

Outcomes