MX8-DSI-OLED1A touch is not calibrated correctly with IMX8Mini (coordinates are offset)

cancel
Showing results for 
Search instead for 
Did you mean: 

MX8-DSI-OLED1A touch is not calibrated correctly with IMX8Mini (coordinates are offset)

266 Views
leviriley
Contributor II

I have an imx8mini running yocto imx-image-full using an MX8-DSI-OLED1A touchscreen as input.

Out of the box this worked fine; was able to get touch input from Qt and directly from Wayland, no calibration required.

Had some unexpected destructive testing that required to replacing the display; the replacement is another (brand new) MX8-DSI-OLED1A.

The new display works as a display and does recognize touch; however it is significantly offset from the screen coordinates.

My colleagues and I have used multiple of these out of the box so this does not make sense.

So,
Is this behavior normal?
Is there a standard remedy or calibration sequence?

Cheers,

Levi

iMX8X #MX8-DSI-OLED1A

0 Kudos
3 Replies

249 Views
leviriley
Contributor II

the whole output from dmesg

0 Kudos

259 Views
leviriley
Contributor II
U-Boot 2021.04-lf_v2021.04+gf7b43f8b4c (Mar 01 2022 - 07:31:56 +0000)

CPU: i.MX8MMQ rev1.0 1800 MHz (running at 1200 MHz)
CPU: Commercial temperature grade (0C to 95C) at 52C
Reset cause: POR
Model: NXP i.MX8MM EVK board
DRAM: 2 GiB
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x52]
Power supply on USB2
TCPC: Vendor ID [0x1fc9], Product ID [0x5110], Addr [I2C1 0x50]
MMC: FSL_SDHC: 1, FSL_SDHC: 2
Loading Environment from MMC... *** Warning - bad CRC, using default environment

[*]-Video Link 0adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22

[0] lcdif@32e00000, video
[1] mipi_dsi@32e10000, video_bridge
[2] adv7535@3d, panel
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22
In: serial
Out: serial
Err: serial
SEC0: RNG instantiated

BuildInfo:
- ATF 05f788b

switch to partitions #0, OK
mmc2(part 0) is current device
flash target is MMC:2
Net: eth0: ethernet@30be0000
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot: 2  1  0
starting USB...
Bus usb@32e40000: Port not available.
USB is stopped. Please issue 'usb start' first.
MMC: no card present
switch to partitions #0, OK
mmc2(part 0) is current device
Scanning mmc 2:1...
47676 bytes read in 3 ms (15.2 MiB/s)
78MMC: no card present
Scanning disk mmc@30b50000.blk...
Disk mmc@30b50000.blk not ready
Scanning disk mmc@30b60000.blk...
Found 3 disks
No EFI system partition
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
BootOrder not defined
EFI boot manager: Cannot load any image
Running BSP bootcmd ...
switch to partitions #0, OK
mmc2(part 0) is current device
Failed to load 'boot.scr'
30792192 bytes read in 109 ms (269.4 MiB/s)
Booting from mmc ...
47676 bytes read in 5 ms (9.1 MiB/s)
Moving Image from 0x40480000 to 0x40600000, end=423f0000
## Flattened Device Tree blob at 43000000
Booting using the fdt blob at 0x43000000
Using Device Tree in place at 0000000043000000, end 000000004300ea3b
adv7535_mipi2hdmi adv7535@3d: Can't find cec device id=0x3c
fail to probe panel device adv7535@3d
mxs_video lcdif@32e00000: failed to get any video link display timings
probe video device failed, ret -22

Starting kernel ...
0 Kudos

263 Views
leviriley
Contributor II
Obiously Touch Related things in boot log:

[ 6.147286] Goodix-TS 1-0014: supply AVDD28 not found, using dummy regulator
[ 6.171739] Goodix-TS 1-0014: supply VDDIO not found, using dummy regulator
[ 6.178115] ak4458 2-0010: Failed to set acks: -6
[ 6.184799] Goodix-TS 1-0014: ID 1158, version: 0100
[ OK ] Started [0;1[ 6.191403] ak4458 2-0012: Failed to set acks: -6
;39mNetwork Time Synchronization[ 6.197473] Goodix-TS 1-0014: Invalid config (1079, 1919, 0), using defaults
[0m.
[ 6.207761] input: Goodix Capacitive TouchScreen as /devices/platform/soc@0/30800000.bus/30a30000.i2c/i2c-1/1-0014/input/input2
0 Kudos