lwip_dhcp_usb example can't detect mobile phone when connected with Huawei Mate40 Pro

cancel
Showing results for 
Search instead for 
Did you mean: 

lwip_dhcp_usb example can't detect mobile phone when connected with Huawei Mate40 Pro

590 Views
Dunzi
Contributor I

Overview:

When run lwip_dhcp_usb_bm/freertos examples on RT1050, it cannot detect the mobilephone device when connect it with Huawei Mate40 Pro using UGREEN OTG usb cable. (https://item.jd.com/27995995406.html).

Note: have tried it using SSK OTG usb cable, and it works well. But we need use UGREEN OTG usb cable in our case.

Reproduce:

  1. Prepare one RT1050-EVKB boards, download the sdk v2.10.0 package from the https://mcuxpresso.nxp.com/.
  2. Unzip the package and build the lwip_dhcp_usb_bm  (iar flexspi_nor_release) project, download it and start to run.
  3. Connect Mate40 Pro mobile phone to the board usb port with UGREEN OTG usb cable, it cannot detect the mobile phone(no attach log printed). The log is shown in below.

 

host init.

 

Expected log:

 

host init.
device cdc attached:
pid=0x108avid=0x12d1 address=1
rndis device attached

************************************************
 DHCP example
************************************************
 DHCP state       : SELECTING
 DHCP state       : REQUESTING
 DHCP state       : BOUND

 IPv4 Address     : 192.168.42.144
 IPv4 Subnet mask : 255.255.255.0
 IPv4 Gateway     : 192.168.42.129


  waiting for getting the IP Address....

 the IP Address of nxp.com is   : 223.119.147.103
ping: send 
223.119.147.103


ping: send 
223.119.147.103

 

 

Labels (1)
Tags (1)
0 Kudos
6 Replies

241 Views
JamesNgo
Contributor III

Hi Dunzi,

I wonder if have any update... I can't get this same sample code to work either on RT1020 both freertos/bm versions regardless of several known working OTG USB cables. On booting up, debug console displays only "Host init."  and USB analyzer shows zero activity.

 

JamesNgo_0-1639076125226.png

 

0 Kudos

569 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @Dunzi,

Unfortunately, I can't reproduce this issue since this specific device and cable. But since only with this specific cable is failing to connect, have you try other ones or check if the specific cable work in other devices?

Best Regards,

Alexis Andalon

0 Kudos

560 Views
Dunzi
Contributor I

Hi, Alexis, 

 Thanks for your quick reply.
  Yes, I have tried this UGREEN USB OTG cable on another mobilde phone  (Smartisan T1), and this example works well. 

  In addition, I have also tried several other UGREEN USB OTG cables to run this examlpe on Mate40 Pro, all failed to detect the mobile phone, so I think it should be compatibility issue, not caused by one defective USB cable.

Best Regard,
Dunzi Qian

0 Kudos

528 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @Dunzi,

Usually, as long as the cable and the design is compliant with the USB protocol and not too long and   it shouldn't matter which cable you use. Does the same cable work with other devices?

Best Regards,

Alexis Andalon

0 Kudos

488 Views
Dunzi
Contributor I

 Yes, @Alexis_A, the same cable works well on another mobilde phone  (Smartisan T1) when run this example, as I mentioned before.

0 Kudos

471 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @Dunzi,

I have mu doubts this is a compatibility issue since using other cables works, I would suggest to try using an oscilloscope or USB analyzer to check to signal and which section of the enumeration process is not done correctly.

Best Regards,

Alexis Andalon

0 Kudos