iMXRT1064-EVK HyperFlash driver error when flashing

cancel
Showing results for 
Search instead for 
Did you mean: 

iMXRT1064-EVK HyperFlash driver error when flashing

343 Views
lars1
Contributor III

I am trying to put constant data in the HyperFlash memory of the iMXRT1064-EVK board. I have compiled the code with the main program located on the internal Flash memory of the MCU and use the external HyperFlahs for storing constant data.

The program is built fine and the memory allocated to the memory but when Flashing I get an error when trying to write to the HyperFlash.

The board resistors are modified so that the HyperFlash is active.

The evkmimxrt1064_flexspi_nor_config.c is modified with the HyperFlash driver according to this thread:

 https://community.nxp.com/thread/494025 

I did chose the HyperFlash driver in the memory setup so I am not sure if that means that another driver is chosen then the one I modified. I can't see any other driver to modify in the project.

I get the following error when trying to Flash the code to the 2 memories:

MCUXpresso IDE RedlinkMulti Driver v11.1 (Jul 7 2020 10:48:32 - crt_emu_cm_redlink build 5)
Found chip XML file in D:/Documents/Dev/OpticalReaderEVK/Debug\MIMXRT1064xxxxA.xml
Reconnected to existing LinkServer process.
============= SCRIPT: RT1064_connect.scp =============
RT1064 Connect Script
DpID = 0BD11477
APID = 0x04770041
Disabling MPU
Configure FlexRAM for 768KB OC RAM, 128KB I-TCM, 128KB D-TCM
Finished
============= END SCRIPT =============================
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0232000006088acd00000000000000000000000097969905
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#7&a567134&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0 after searching for a good core
debug interface type = Cortex-M7 (DAP DP ID 0BD11477) over SWD TAP 0
processor type = Cortex-M7 (CPU ID 00000C27) on DAP AP 0
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 00000C27. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C Gen SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 Gen DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E Gen (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 Gen ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 CSt ARM ETMv4.0 type 0x13 Trace Source - Core
ROM 2 E0042000: CID B105900D PID 04004BB906 CSt type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CSt type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 Sys (type 0x0)
NXP: MIMXRT1064xxxxA
DAP stride is 1024 bytes (256 words)
Inspected v.2 External Flash Device on SPI using SFDP JEDEC ID MIMXRT1064.cfx
Image 'iMXRT1064_SFDP_QSPI Jul 7 2020 10:54:42'
Opening flash driver MIMXRT1064.cfx
Sending VECTRESET to run flash driver
Flash variant 'RT1064' detected (4MB = 64*64K at 0x70000000)
Closing flash driver MIMXRT1064.cfx
Inspected v.2 External Flash Device on SPI using SFDP JEDEC ID MIMXRT1060_SFDP_HYPERFLASH.cfx
Image 'iMXRT10xx SFDP Jul 7 2020 10:54:48'
Opening flash driver MIMXRT1060_SFDP_HYPERFLASH.cfx
Sending VECTRESET to run flash driver
Driver V.2 dynamic startup failed - driver Init provided no flash parameters
Flash Driver V.2 startup failed - rc Ef(55): Dynamic flash driver startup failed to provide flash parameters.
Terminate (0x0, 0x0, 0x0) status 0x40 - driver reports init failure - EXTSPIJ driver rc 7000 (0x1B58)
chip initialization failed - Ef(55): Dynamic flash driver startup failed to provide flash parameters.
failed to initialize flash driver MIMXRT1060_SFDP_HYPERFLASH.cfx

Any help is much appreciated.

Thanks.

Labels (1)
Tags (2)
0 Kudos
4 Replies

284 Views
lars1
Contributor III

Hi Victor,

Thank you for your reply. I have made the hardware adjustments and changed the resistors as indicated in the hardware documentation. I can program the Hyperflash separately and I can programmatically access it with the SDK project FlexSPIHyperFlashPollingTransfer so the hardware is no issue.

After discussing this with Segger the problem may be in the flashing algorithm with the JLink. The Hyperflash can be programmed separately with the JLink without a problem and so can the internal on-chip flash, but not both memories in the same operation. They are currently investigating this and I will post the findings here.

Thanks,

Lars

0 Kudos

284 Views
lars1
Contributor III

Hi Victor,

Thank you for your reply. I am using the on-chip Flash of the RT1064 for my program code so I do not need to modify it.

The problem is that I cannot access the external HyperFlash (U19, S26KS512SDPBHI02) with the current driver or something is wrong with my setup.

Writing the code to the internal Flash works fine but I get an error when trying to write const data to the HyperFlash.

I appreciate any advice.

Regards,

Lars

0 Kudos

284 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hi Lars, 

I apologize for the misunderstanding. In the RT1064-EVK, FlexSPI1 interface is connected by default to the external QSPI NOR flash, no the Hyperflash. If you want to work with the Hyperflash you have to make some hardware changes to the board. These changes are specified in the readme file of the flexspi_hyper_flash_polling_transfer example project of the SDK. 

Have a great day,

Victor

-------------------------------------------------------------------------------

Note:

- If this post answers your question, please click the "Mark Correct"button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored

Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

-------------------------------------------------------------------------------

0 Kudos

284 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello, Lars 

Please refer to the following community document, How to use the RT1064 on-chip flash as NVM. This document will guide you on how to use the on-chip flash as NVM so you can write, erase and delete it without problems. 

Have a great day,

Victor

-------------------------------------------------------------------------------

Note:

- If this post answers your question, please click the "Mark Correct"button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored

Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

-------------------------------------------------------------------------------

0 Kudos