eMMC on USDHC2 not initialising on IMXRT1064

cancel
Showing results for 
Search instead for 
Did you mean: 

eMMC on USDHC2 not initialising on IMXRT1064

567 Views
gredpath
Contributor III

We have a design with both an SD Card and eMMC, the SD card on the GPIO_SD_B0_00-B0_05 (USDHC1and the eMMC on GPIO_SD_B1_00 to B1-11. the SD Card works perfectly switching to 1.8V. The eMMC fails to initialise usinge freeRTOS example code, we have had to port it to USDHC2 from USDHC1, is there an example that runs directly on USDHC2, as the issue is probably our porting. The code is based on evkmimxrt1064_mmccard_freertos.

Any help would be appreciated.

0 Kudos
5 Replies

473 Views
gredpath
Contributor III

Thanks for your reply, I have disabled DQS as you suggested but the eMMC example still doesn't work, are there any other changes we need to make to the eMMC code on uSDHC1 to get it to work on USDHC2?

Regards

George

0 Kudos

537 Views
gredpath
Contributor III

Apologies, I should have asked, how do I disable DQS functionality?

0 Kudos

507 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hi George,

Please check this community thread where another customer disable DQS feature and was able to use USDHC2. Please note that we do not recommend doing this as my colleague mentioned.

Solved: imxRT1060 USDHC2 CMD pin configuration issue - NXP Community

Best regards,

Felipe

0 Kudos

549 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hi,

This issue may be caused by the FlexSPI_DQS (GPIO_SD_B1_05) pin. This pin needs to be floating for QSPI Flash RW at 133 MHz.

As you are modifying this pin functionality the QSPI may not be booting correctly. You can use this pin if you disable DQS functionality but you will not achieve highest performance.

Have a great day,

Felipe

-------------------------------------------------------------------------------

Note:

- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored. Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

------------------------------------------------------------------------------ 

0 Kudos

540 Views
gredpath
Contributor III

I have added the relavent page of the schematic. The issue is that GPIO_SD_B1_05 is the eMMC CMD line, I have a 50K pullup on that line.

Thanks

George

0 Kudos