Using MfgTool2 with imxRT1052

cancel
Showing results for 
Search instead for 
Did you mean: 

Using MfgTool2 with imxRT1052

569 Views
davidouatt08
Contributor I

Hello,

I'm using mfgtool2 to load my application into imxRT1052. Project is built under MCUXpresso IDE 10.3.1 with SDK v2.5. In the project properties, i define Flash at address 0x60000000.

To create SB file, I have FlashLoader_RT1050_1.1 version (with bd files used by elftosb .

Commands to generate bd file:

.\elftosb.exe -f imx -V -c ../../bd_file/imx10xx/imx-flexspinor-normal-unsigned.bd -o ivt_flexspi_nor_MyMCUXpressoOutputFile.bin MyMCUXpressoOutputFile.axf

.\elftosb.exe -f kinetis -V -c ../../bd_file/imx10xx/program_flexspinor_image_HyperFlash.bd -o boot_image.sb ivt_flexspi_nor_MyMCUXpressoOutputFile_nopadding.bin

The boot_image.sb file is then created.

In cfg.ini, I have defined MXRT105X-DevBoot and in ucl2.xml file, I set timeout="115000" under MXRT105X-DevBoot description.

When I open mfgtool2, it shows HID-Compliand Device but fails to download the binary file into the Hyperflash Memory.

MfgTool. log file shows :

ModuleID[2] LevelID[10]: Get Property 1. [WndIndex:0] {

"command" : "get-property",

"response" : [ 1258422528 ],

"status" : {

"description" : "0 (0x0) Success.",

"value" : 0

}

}


ModuleID[2] LevelID[10]: ExecuteCommand--Blhost[WndIndex:0], Body is receive-sb-file "Profiles\MXRT105X\OS Firmware\boot_image.sb"
ModuleID[2] LevelID[10]: PortMgrDlg(0)--Path=\\.\hid#vid_15a2&pid_0073#6&202160b0&2&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
ModuleID[2] LevelID[1]: Program Boot image [WndIndex:0] {

"command" : "receive-sb-file",

"response" : [],

"status" : {

"description" : "20106 (0x4E8A) kStatus_FlexSPINOR_CommandFailure",

"value" : 20106

}

}

Can you help with this and explain what 20106 (0x4E8A) kStatus_FlexSPINOR_CommandFailure means please?

Best Regards

David

Labels (1)
0 Kudos
7 Replies

331 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hello David,

 

First of all, I just want to let you know that you are not using the latest version of MCUXpresso IDE which is 11.1.1 and MCUXpresso SDK which is 2.7.0. We always recommend to use our latest tools so you can have the best customer experience.

 

Regarding your issue, I recommend you to check the community document below which explains in detail how to generate a bootable image for the RT1050.

 

Generating a Bootable Image for the RT1050 

 

If you have trouble with any of the steps described above please do not hesitate to let me know.

 

Best regards,

Felipe

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

331 Views
davidouatt08
Contributor I

Hello Felipe,

Thanks for your reply. 

I have followed the steps described in the document but it still doesnt work.

Do you know what the following error code means?

"20106 (0x4E8A) kStatus_FlexSPINOR_CommandFailure"

Regards

David

0 Kudos

331 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Could you please let me know the Hyperflash you are using on your side?

 

Regards,

Felipe

0 Kudos

331 Views
davidouatt08
Contributor I

Felipe, 

I use Cypress S26KS128SDPBHI020.

Regards

David

0 Kudos

331 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

I recommend you to try the test mentioned in the below link by Cypress, this will help you make sure your memory is still working.

 

https://community.cypress.com/thread/42382

 

Best regards,

Felipe

0 Kudos

331 Views
davidouatt08
Contributor I

I did the test and, when I am in debug mode running in SDRAM, I can access the Cypress Hyperflash, erase and write and read back to check the data. So I am sure the Hyperflash is still working. 

I searched the internet to find another solution but I didnt find yet. I am open I you have any other idea?

Regards

David

0 Kudos

331 Views
FelipeGarcia
NXP TechSupport
NXP TechSupport

Hello David,

 

It would be easier if you share with me the steps you are doing so I can replicate it in my side. Please provide detailed description.

 

Best regards,

Felipe

0 Kudos