Usb Cdc VCom error on Windows

cancel
Showing results for 
Search instead for 
Did you mean: 

Usb Cdc VCom error on Windows

175 Views
Contributor II

    Dear sirs,

we're using:

  • MIMXRT1060-EVK board
  • MCUXpresso IDE v11.1.0 [Build 3209][2019-12-12]
  • SDK_2.x_EVK-MIMXRT1060 Version 2.7.0
  • macOS Catalina 10.15.3
  • Windows10 1909

We've imported SDK projects:

  • evkmimxrt1060_dev_cdc_vcom_bm
  • evkmimxrt1060_dev_cdc_vcom_rtos

They show the same result.

We've been using screen utility on Mac, with command:

"screen /dev/tty.usbmodem142101 115200"

We can write some words on the terminal, we can read them (echo behavior), then we quit the utility (Ctrl+A+K).

We've been starting again the utility and we've been trying again to write and read something.

Everything works fine on Mac.

On Windows, we've been using PuTTY release 0.72 (we've been trying also TeraTerm with same result).

The echo of characters works fine the first time utility is used.

At the second usage, the first character is lost.

That means, the result is correct the first time the program is used, but the second one it is lost the first character.

So, we've been deciding to try a different usb stack, using Zephyr OS.

It has been using the sample located at:

samples/subsys/usb/cdc_acm

Everything works fine on Mac and on Windows.

So, we guess it could be a problem regarding Usb Stack/Driver.

Wireshark is used to monitor the USB protocol and it shows that the board does not respond correctly on the first character at the second execution.

Please, look at the screenshots.

We're wondering if someone can suggest a solution.

Best Regards,

Daniele

Labels (1)
3 Replies

57 Views
NXP TechSupport
NXP TechSupport

Hi Daniele, 

I wasn't able to reproduce the behavior you mentioned on my Windows 10 PC. I loaded the example into my EVK and I open a serial terminal (Tera Term) then I send a couple of characters and I was able to see everything fine. After that, I close the serial terminal and opened it again and I also receive all the characters without any problems. 

The only difference in the test environment is that I'm using the newest version of MCUXpresso IDE (11.1.1). Could you please try to reproduce this behavior with this version of the IDE? 

Best Regards, 

Victor 

0 Kudos

57 Views
Specialist V

Hi Daniele

Could you try this ? https://www.utasker.com/iMX/RT1060.html

It has composite USB-MSD and USB-CDC (on VCOM it will echo and also give a command line menu, with a command to perform USB-CDC to LPUART1 bridging).

Do you find errors on either Windows or MAC?

Regards

Mark
[uTasker project developer for Kinetis and i.MX RT]

0 Kudos

57 Views
Contributor II

    Hi Mark,

thank you for your support.

Echo works fine on Mac but not on Windows.

On Windows, after a open/close of virtual com, it doesn't echo the first character (the others are correctly managed).

We've yet tested a different Os, like Zephyr and everything works fine.

We'll test uTasker, too, but, at the moment, we're interested in using the Nxp usb stack.

BR,

Daniele

0 Kudos