Unsupported version of the PWM Driver (and SAI driver)

cancel
Showing results for 
Search instead for 
Did you mean: 

Unsupported version of the PWM Driver (and SAI driver)

Jump to solution
160 Views
Contributor III

Hi

With the SDK config tool I get theese warnings:

Issue: Unsupported version of the PWM Driver in the toolchain/IDE project. Required: 2.1.0, actual: 2.2.1.

Issue: Unsupported version of the SAI Driver in the toolchain/IDE project. Required: 2.2.1, actual: 2.3.1.

I am suprised that the versions of each module is not compatible with echother in the SDK.

The procect seems to compile, so it must be minor changes to the updatede drivers.

Is it safe to ignore?

 

Kasper

0 Kudos
1 Solution
104 Views
NXP TechSupport
NXP TechSupport

Hi Kasper,

So you are importing a configuration from a different project to the new created project? If so, then that is the cause of the warnings. These peripherals were initiated using old version of the drivers so there is a mismatch with the new SDK drivers.

To get rid of this warnings please remove the SAI and PWM component and create them again in the same project using config tools.

Best regards,

Felipe

View solution in original post

0 Kudos
6 Replies
151 Views
NXP TechSupport
NXP TechSupport

Hi Kasper,

Could you please provide the SDK and SDK version you are working on? Also please provide the version of the MCUXpresso IDE you are using.

I recommend you to update to latest version so you do not have this kind of problems but if you are using latest then please provide how can I replicate this on my side with the information requested above.

Best regards,

Felipe

0 Kudos
139 Views
Contributor III

Hi,

I am using the MIMXRT1064DVL6A.

Kasper

 

0 Kudos
125 Views
NXP TechSupport
NXP TechSupport

Hi Kasper,

I have imported same version of drivers in a project of MIMXRT1064-EKV using MCUXpresso IDE v11.2.1 and I cannot see this warning. Could you please provide how can I replicate this issue on my side?

Regards,

Felipe

0 Kudos
115 Views
Contributor III

Hi

Sorry for the delay.

I have attached a mex file from my project, and a document describing how I can create a new project with the same problem, inclusive the warnings/errors. Finally a folder with the resulting project (SDK-files must be refreshed(generated).

I have upgraded the SDK to the new version 2.8.5 with same result.

Hope that there is a reason for my problems.

 

BR

Kasper

0 Kudos
105 Views
NXP TechSupport
NXP TechSupport

Hi Kasper,

So you are importing a configuration from a different project to the new created project? If so, then that is the cause of the warnings. These peripherals were initiated using old version of the drivers so there is a mismatch with the new SDK drivers.

To get rid of this warnings please remove the SAI and PWM component and create them again in the same project using config tools.

Best regards,

Felipe

View solution in original post

0 Kudos
92 Views
Contributor III

I had to remove the components from the config tool. I have tried to remove the SDK component with no success.

Also solved the problem with the USB.

The rest is just annoying warnings. I only need the "Record" channel for the SAI interface, so the config tool should not complain that the "Play" TX pins was not routed.

Thanks

 

0 Kudos