Unable to use sdphost to RT1060 evk

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to use sdphost to RT1060 evk

760 Views
markson
Contributor II

Hi community,

I'm trying to connect to RT1060 EVK via UART on my mac

firstly, I turn the SW7 to 0b0001 the serial downloader mode and then

as the picture below shows the RX and TX goes to the pin 1 and 2 in J22 and the ground pin goes to pin 7 on J25

the serial com on my mac is /dev/cu.usbserial-001IKOQ

and try the command:

sudo ./sdphost -p /dev/cu.usbserial-001IKOQ -- read-register 0x0000

then the console freeze without any response

IMG_1946.JPG

And I tried the usb method by connect to J9 USB  find the pid and vid of the USB device in mac system information

then type

IMG_1947.JPG

sudo ./sdphost -u 0x1fc9,0x0135 -- read-register 0x0000

then the console throw me: "Error handler" quickly (seems nothing happening)

Could anyone tell me how can I solve this problem, Thank you

Lin

Labels (1)
Tags (1)
4 Replies

501 Views
michael_fairman
Contributor I

Originally I ran into what sounds like the same problem with USB,  and made the following change to middleware/mcu-boot/tools/src/blfwk/src/hid-mac.c to cope with exclusive access:

static int init_hid_manager(void)

{

    IOReturn res;

    /* Initialize all the HID Manager Objects */

    hid_mgr = IOHIDManagerCreate(kCFAllocatorDefault, kIOHIDOptionsTypeNone);

    IOHIDManagerSetDeviceMatching(hid_mgr, NULL);

    IOHIDManagerScheduleWithRunLoop(hid_mgr, CFRunLoopGetCurrent(), kCFRunLoopDefaultMode);

    res = IOHIDManagerOpen(hid_mgr, kIOHIDOptionsTypeNone);

-    return (res == kIOReturnSuccess) ? 0 : -1;

+    return (res == kIOReturnSuccess) || (res == kIOReturnExclusiveAccess) ? 0 : -1;

}

Then after rebuilding sdphost and blhost I was able to use them natively on the Mac.  I'm not sure if this is 100% correct but it does work for me.

For UART access, removing J45 and J46 then using pin 2 of each to connect a 3.3v TTL UART works.  From your picture it looks like you were connecting to UART3 on the Arduino connector and the serial downloader can't see that.

- Mike

501 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Lin,

   Do you already solve the problem?


Have a great day,
Kerry

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

501 Views
markson
Contributor II

Hi Kerry,

I still can't use any of the command line tools on Mac(High Sierra 10.13.6), All gives me "Error handler" immediately. So  I have to try it on Win10 running in VMWare fusion on my mac, so far the USB-HID mode of sdphost works , "read-register" gives me correct result. I still want these tool work natively on my mac though

0 Kudos

501 Views
markson
Contributor II

Just found this on elftosb User's guide

Currently, elftosb tool on Mac OS can support Kinetis devices but not i.MX devices.

So I assume sdphost doesn't support imx on Mac as wel

0 Kudos