USB with graphical interface with IMXRT1062

cancel
Showing results for 
Search instead for 
Did you mean: 

USB with graphical interface with IMXRT1062

219 Views
Contributor II

Good morning everyone

I'm using the mimxrt1060-evk

I need to integrate usb host functionality in a design with graphical interface.

To do this I mixed the examples "emwin slide show" and the host_msd_fafts_bm.‌

Because of the memory needed by emwin I need to use the external SDRAM for data.

With this configuration the usb example doesn't work.

To isolate the problem I tried simply to change the memory used by the usb example alone from the default SRAM_DTC to board_sdram moving up this latter to the first position in memory configuration. With this memory configuration the usb example doesn't work anymore. Any suggestion?

Thank you in advance for collaboration.

pastedImage_1.png

Labels (1)
0 Kudos
6 Replies

14 Views
Contributor V

I have a similar question outstanding for both USB host examples and FatFS...  so far the only resolution was to place the entire Heap and Stack into a noncached memory section. 

I would love to know which control structures for FatFS and USB Host need to explicitly reside in non-cached memory.

0 Kudos

14 Views
Contributor II

Hello Mr. King

How did you place the heap and stack in noncached memory? I tried with these settings but the program crashes..

pastedImage_1.png

pastedImage_3.png

Thank you for collaboration.

Best regards

0 Kudos

14 Views
Contributor V

Sorry, it should be the Global Data placement:

Properties_for_evkmimxrt1060_hello_world_fresh.jpg

0 Kudos

14 Views
Contributor II

Hello Mr. King

With global data placement in SRAM_DTC you put ALL the data in that section. the usb works but the emwin graphical interface overflows. Are you using the graphical interface with usb?

Best regards

0 Kudos

14 Views
Contributor V

Sorry, I'm not using emWin, but are you able to place the frame buffer used by emWin into a different memory segment explicitly? 

0 Kudos

14 Views
Contributor II

I placed the frame buffer in external SDRAM and now it works correctly.

Thank you for collaboration.

0 Kudos