Serial Downloader / Baud Rate

cancel
Showing results for 
Search instead for 
Did you mean: 

Serial Downloader / Baud Rate

Jump to solution
157 Views
jaredm
Contributor III

What is the default Serial Downloader baud rate for the RT1052?

I am trying to program RT1052 fuses using blhost and LPUART1. The default baud rate of blhost is 57600, but this does not work. I have tried 115200 and I get a reasonable response, but blhost still has issues:

    blhost -p COM6,115200 -t 50000 -d -- get-property 1
    [5a a6]
    <5a>
    Ping responded in 1 attempt(s)
    <a8>
    Error: Initial ping failure: Invalid packet type.

Why am I getting this error? Is it due to baud rate or something else?

I looked at the serial lines with a logic analyzer, and everything appears to be OK. Image attached.

0 Kudos
1 Solution
136 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi jaredm,

   If you want to connect the RT in serail download mode, I suggest you can try the MCUbootutility tool at first, that tool use the blhost and print the log:

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\sdphost\win\sdphost -t 50000 -p COM49,115200 -j -- write-file 539001344 C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\src\targets\MIMXRT1052\ivt_flashloader.bin
toolStatus: 0
commandOutput: {
"command" : "write-file",
"response" : [ 2290649224 ],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\sdphost\win\sdphost -t 50000 -p COM49,115200 -j -- jump-address 539001344
toolStatus: 0
commandOutput: {
"command" : "jump-address",
"response" : [],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 1 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1258422528 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 1 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1258422528 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 24 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1409351680 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

 

You can download that tool from this link:

https://github.com/JayHeng/NXP-MCUBootUtility/releases/tag/v3.0.0
the related user manual is:
https://github.com/JayHeng/NXP-MCUBootUtility

Please try it at first, whether this tool can connect your chip or not? Normally, we use 115200bps.

If the mcubootutility works on your side, you can compare your log with the mcubootutility log, which detail things you have lost.

If you still have questions about it after you test with the mcubootutility tool, just kindly let me know.

Best Regards,

Kerry

View solution in original post

0 Kudos
5 Replies
127 Views
jaredm
Contributor III

Hi Kerry,

I tried what you suggested. Using sdphost was successful, but blhost still fails. Do you think it is because I am using LPUART1 instead of USB1?

Below is the response I get.

 

sdphost -t 15000 -p COM6,115200 -j -- write-file 539001344 ivt_flashloader.bin
{
"command" : "write-file",
"response" : [ 2290649224 ],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

sdphost -t 1000 -p COM6,115200 -j -- jump-address 539001344
{
"command" : "jump-address",
"response" : [],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

blhost -t 1000 -p COM6,115200 -j -- get-property 1 0
{
"command" : "ping",
"response" : [],
"status" : {
"description" : "10501 (0x2905) Invalid packet type.",
"value" : 10501
}
}

0 Kudos
119 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi jaredm

  Do you use the MCUbootUtility tool directly?  Instead of your own input the log, can you connect it or not?

  Please also share me your MCUBootUtility tool test result and the log.

 

Best Regards,

kerry

0 Kudos
108 Views
jaredm
Contributor III

Hi Kerry,

I have found the problem, it was the file ivt_flashloader.bin. The file included with Flashloader_RT1050_1.1 FAILS, but the file included with MCUBootUtility SUCCEEDS.

Flashloader_RT1050_1.1\Tools\mfgtools-rel\Profiles\MXRT105X\OS Firmware\ivt_flashloader.bin   -   FAILURE

NXP-MCUBootUtility-3.0.0\src\targets\MIMXRT1052\ivt_flashloader.bin   -   SUCCESS

Thanks for helping me debug this problem.

jaredm

0 Kudos
101 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi jaredm,

  Thanks for your updated information.

   The Flashloader_RT1050_1.1 is old, and normally, we use the newest SDK flashloader.

   To me, I prefer to use the MCUbootUtility tool to check the downloading, as that is very simple and easy to use, that's why I suggest you try it at first. Then you even can totally follow the MCUbootUtility tool command to write the detail command to your board.

  Anyway, that's good to hear you already make it works.

  If you have any questions in the future, welcome to create a new question post.

 

Best Regards,

Kerry

0 Kudos
137 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi jaredm,

   If you want to connect the RT in serail download mode, I suggest you can try the MCUbootutility tool at first, that tool use the blhost and print the log:

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\sdphost\win\sdphost -t 50000 -p COM49,115200 -j -- write-file 539001344 C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\src\targets\MIMXRT1052\ivt_flashloader.bin
toolStatus: 0
commandOutput: {
"command" : "write-file",
"response" : [ 2290649224 ],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\sdphost\win\sdphost -t 50000 -p COM49,115200 -j -- jump-address 539001344
toolStatus: 0
commandOutput: {
"command" : "jump-address",
"response" : [],
"status" : {
"description" : "1450735702 (0x56787856) HAB disabled.",
"value" : 1450735702
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 1 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1258422528 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 1 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1258422528 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

Executing: C:\KerryPC\tool\NXP-MCUBootUtility-2.4.0\tools\blhost2_3\win\blhost -t 50000 -p COM49,115200 -j -- get-property 24 0
toolStatus: 0
commandOutput: {
"command" : "get-property",
"response" : [ 1409351680 ],
"status" : {
"description" : "0 (0x0) Success.",
"value" : 0
}
}

 

You can download that tool from this link:

https://github.com/JayHeng/NXP-MCUBootUtility/releases/tag/v3.0.0
the related user manual is:
https://github.com/JayHeng/NXP-MCUBootUtility

Please try it at first, whether this tool can connect your chip or not? Normally, we use 115200bps.

If the mcubootutility works on your side, you can compare your log with the mcubootutility log, which detail things you have lost.

If you still have questions about it after you test with the mcubootutility tool, just kindly let me know.

Best Regards,

Kerry

View solution in original post

0 Kudos