Secure JTAG mode

cancel
Showing results for 
Search instead for 
Did you mean: 

Secure JTAG mode

Jump to solution
758 Views
ffloree
Contributor III

I verified it in 1052 EVK board by following AN12419, but it always reports "ERROR while parsing value for DRPre. Using default: 0." then nothing when I run command line whatever  JTAG_MODE pin is high or low:

"Jlink.exe -JLinkScriptFile "Devices\NXP\iMXRT105x\NXP_RT1052_SecureJTAG.JlinkScript" -Device MCIMXRT1052 -If JTAG -Speed 32 -Autoconnect 1 -JTAGConf -1, -1"

File NXP_RT1052_SecureJTAG.JlinkScript only includes the function InitTarget(void) in section 4.2 of AN12419, actually, this file have not yet got to run before the error above.

All the fuses mentioned in section 3.1 have been blown, JTAG_MODE pin was connected to R67 (high), JLink version is v6.30i.

But when I run JLink step by step, the result is:

C:\Program Files (x86)\SEGGER\JLink_V630i>JLink.exe
SEGGER J-Link Commander V6.30i (Compiled Mar 23 2018 18:14:43)
DLL version V6.30i, compiled Mar 23 2018 18:14:24

Connecting to J-Link via USB...O.K.
Firmware: J-Link V9 compiled Oct 25 2018 11:46:07
Hardware version: V9.20
S/N: 609200376
License(s): RDI, FlashBP, FlashDL, JFlash, GDB
VTref = 3.277V

Type "connect" to establish a target connection, '?' for help
J-Link>connect
Please specify device / core. <Default>: MCIMXRT1052
Type '?' for selection dialog
Device>
Please specify target interface:
J) JTAG (Default)
S) SWD
TIF>J
Device position in JTAG chain (IRPre,DRPre) <Default>: -1,-1 => Auto-detect
JTAGConf>
Specify target interface speed [kHz]. <Default>: 4000 kHz
Speed>32
Device "MCIMXRT1052" selected.

Connecting to target via JTAG
TotalIRLen = 5, IRPrint = 0x01
JTAG chain detection found 1 devices:
#0 Id: 0x088C301D, IRLen: 04, JTAG-DP
TotalIRLen = 5, IRPrint = 0x01
JTAG chain detection found 1 devices:
#0 Id: 0x088C301D, IRLen: 04, JTAG-DP

****** Error: CPU-TAP not found in JTAG chain

TotalIRLen = 5, IRPrint = 0x01
JTAG chain detection found 1 devices:
#0 Id: 0x088C301D, IRLen: 04, JTAG-DP
TotalIRLen = 5, IRPrint = 0x01
JTAG chain detection found 1 devices:
#0 Id: 0x088C301D, IRLen: 04, JTAG-DP

****** Error: CPU-TAP not found in JTAG chain

Cannot connect to target.
J-Link>exit

Before burning these fuses, the connection is correct. Fuse information below, did I miss something?

pastedImage_5.png

Labels (1)
0 Kudos
1 Solution
431 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi tom fang ,

   If you want to use JTAG, you also need to do some hardware modification on the MIXMRT1050-EVKB:

1) Burn fuse DAP_SJC_SWD_SEL from 0 to 1 to choose JTAG;

2) DNP R323,R309,R152 to isolate JTAG multiplexed signals.

3) Keep off J47~J50 to isolate board level debugger.

Do you modify the hardware point?

If not, please try it again.

If you still have questions about it, please kindly let me know.

 

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
---------------------------------------------------------------------------

View solution in original post

4 Replies
432 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi tom fang ,

   If you want to use JTAG, you also need to do some hardware modification on the MIXMRT1050-EVKB:

1) Burn fuse DAP_SJC_SWD_SEL from 0 to 1 to choose JTAG;

2) DNP R323,R309,R152 to isolate JTAG multiplexed signals.

3) Keep off J47~J50 to isolate board level debugger.

Do you modify the hardware point?

If not, please try it again.

If you still have questions about it, please kindly let me know.

 

Have a great day,
Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
---------------------------------------------------------------------------

View solution in original post

26 Views
vanessa_dis
Contributor II

What do you mean with the step 2? What i should do?

0 Kudos
431 Views
ffloree
Contributor III

Thanks Kerry, it has been fixed, two steps:

1. Remove the command line option: "Jlink.exe -JLinkScriptFile "Devices\NXP\iMXRT105x\NXP_RT1052_SecureJTAG.JlinkScript" -Device MCIMXRT1052 -If JTAG -Speed 32 -Autoconnect 1"

2. Remove CMSIS-DAP (J32 and J33)

0 Kudos
431 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Thanks a lot for your updated information.

And it's so good to hear you make it works! Congratulations.

Have a great day,
Kerry

 

0 Kudos