SDK "lpuart_interrupt_transfer" example using LPUART3

cancel
Showing results for 
Search instead for 
Did you mean: 

SDK "lpuart_interrupt_transfer" example using LPUART3

Jump to solution
91 Views
petrama
Contributor II

On the MIMXRT1060-EVK I am executing the SDK "lpuart_interrupt_transfer" example. It works fine using LPUART1, but if I try to communicate via the Arduino pins using LPUART3, something goes wrong. It is as if the baud rate(115200) is off. Data is sent both ways but not received correctly. The initialization text is sent but received a rubbish at the connected terminal. If 8 characters are entered in the terminal the program recognizes this, but the characters are not received and echoed correctly.

All I have changed in the example is the below define in lpuart_interrupt_transfer.c:

#define DEMO_LPUART LPUART3

What else do I need to edit? Does my problem have something to do with LPUART3 being setup for Bluetooth?

Labels (1)
Tags (1)
0 Kudos
1 Solution
64 Views
petrama
Contributor II

Just learned today that a Max232 TTL/RS232 adapter is needed. It inverts HIGH and LOW and shields the board from too high voltages. ( I hope, that I havn't already damaged the i.MX board  )

View solution in original post

0 Kudos
2 Replies
65 Views
petrama
Contributor II

Just learned today that a Max232 TTL/RS232 adapter is needed. It inverts HIGH and LOW and shields the board from too high voltages. ( I hope, that I havn't already damaged the i.MX board  )

View solution in original post

0 Kudos
81 Views
petrama
Contributor II

I just want to mention that I have tried with other baud rates to no effect

0 Kudos