RT1015 Cannot upgrade with NXP-MCUBootUtility

cancel
Showing results for 
Search instead for 
Did you mean: 

RT1015 Cannot upgrade with NXP-MCUBootUtility

Jump to solution
246 Views
kensu
Contributor V

Hi 

I am trying NXP-MCUBootUtility tool to upgrade RT1015 EVB,

My step is 

1. set the EVB switch(SW8) to download mode.

2. power on EVB

3. Open NXP-MCUBootUtility, MCU Device set to i.NXRT1015, boot Device is FLEXSPI NOR.

4. Port Setup to USB-HID, and Connect to ROM. And It had detect my EVB.

5. Select Application image file to my bin file.(I use the SDK vkmimxrt1015_dev_cdc_vcom_freertos and I use bin file format)

6. Click All-In-One-Action

7. After Process is complete, I switch to normal mode.

8. Reset EVB again, the boot image cannot run.

Does I loss some step or make wrong setting?

pastedImage_1.png

pastedImage_2.png

Regards

Ken

Labels (1)
1 Solution
155 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Ken Su,

  Thanks for your question at first.

  Today I have tested it on my side, it's really the interesting things and the test result, and only find in the MCUXpresso IDE, IAR project works perfectly.

  I find the main issue is caused by the IVT reset entry point in the MCUBootUtility.

pastedImage_1.png

Although it is using the reset handler:

pastedImage_2.png

  If you use the elftosb tool to generate the sb file, you will find more detail:

  imx-flexspinor-normal-unsigned.bd

pastedImage_3.png

entryPointAddress = 0x60002000; generate the related file and the sb file, it works.

entryPointAddress = 0x600022A9; generate the related file and the sb file, it is failed 

So now, two workaround for you:

1. Use IAR project

 1)  In the reprocessor options configuration, you need:

XIP_BOOT_HEADER_ENABLE=0

2).  entry symbol modified to Reset_Handler

pastedImage_4.png

Then you can generate the .srec file, and use the mcubootutility tool, you will download it and works OK.

I also attach my generated the dev_cdc_vcom_fressrtos iar .srec files for your reference

pastedImage_5.png

pastedImage_6.png

2. MCUXpresso IDE

   You can use the \SDK_2.7.0_EVK-MIMXRT1015\middleware\mcu-boot\bin\Tools\elftosb\win

   imx-flexspior-normal-unsigned.bd 

options {
flags = 0x00;
startAddress = 0x60000000;
ivtOffset = 0x1000;
initialLoadSize = 0x2000;
//DCDFilePath = "dcd.bin";
# Note: This is required if the default entrypoint is not the Reset_Handler
# Please set the entryPointAddress to Reset_Handler address
entryPointAddress = 0x60002000;
}

sources {
elfFile = extern(0);
}

section (0)
{
}

Then generate the .sb file, and use the MFGtool download the code, it also works, I also upload the related files for your reference.

For the detail MCUBootUtility reset handler in the IVT issue, I will check internally, it's really the strange issues.

Any updated information, will let you know.

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

5 Replies
155 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi  Ken Su,

  Thank you for your interest in the NXP MIMXRT product, I would like to provide service for you.

   Could you please download the MCUbootUtility tool attached firmware:

\NXP-MCUBootUtility-2.3.0\apps\NXP_MIMXRT1015-EVK_Rev.A\led_blinky_0x60002000.srec

Whether this led blinky firmware can works or not?

Please also note, after you download the code, you need to modify the boot mode to internal boot mode instead of the serial download mode.

Wish it helps you!

If you still have questions about it, please kindly let me know.

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
155 Views
kensu
Contributor V

Hi Kerry

Thanks for your comment,

I check the led_blinky_0x60002000.srec, it's no problem.

pastedImage_1.png

The demo run OK.

Regards

Ken

0 Kudos
155 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Ken Su,

   Check your vkmimxrt1015_dev_cdc_vcom_freertos, whether it contains the SDRAM or not?

  If it contains the SDRAM, you need to add the SDRAM DCD cfg in the DCD configuration area.

Wish it helps you!

If you still have questions about it, please kindly let me know.

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
155 Views
kensu
Contributor V

Hi Kerry

I don't use SDRAM.

I don't modify the memory setting.

pastedImage_1.png

And I think RT1015 cannot connect SDRAM.

Any other suggestion?

Should I use srec format file?

If I use bin file, is the base address 0x6000000?

Regards

Ken

0 Kudos
156 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Ken Su,

  Thanks for your question at first.

  Today I have tested it on my side, it's really the interesting things and the test result, and only find in the MCUXpresso IDE, IAR project works perfectly.

  I find the main issue is caused by the IVT reset entry point in the MCUBootUtility.

pastedImage_1.png

Although it is using the reset handler:

pastedImage_2.png

  If you use the elftosb tool to generate the sb file, you will find more detail:

  imx-flexspinor-normal-unsigned.bd

pastedImage_3.png

entryPointAddress = 0x60002000; generate the related file and the sb file, it works.

entryPointAddress = 0x600022A9; generate the related file and the sb file, it is failed 

So now, two workaround for you:

1. Use IAR project

 1)  In the reprocessor options configuration, you need:

XIP_BOOT_HEADER_ENABLE=0

2).  entry symbol modified to Reset_Handler

pastedImage_4.png

Then you can generate the .srec file, and use the mcubootutility tool, you will download it and works OK.

I also attach my generated the dev_cdc_vcom_fressrtos iar .srec files for your reference

pastedImage_5.png

pastedImage_6.png

2. MCUXpresso IDE

   You can use the \SDK_2.7.0_EVK-MIMXRT1015\middleware\mcu-boot\bin\Tools\elftosb\win

   imx-flexspior-normal-unsigned.bd 

options {
flags = 0x00;
startAddress = 0x60000000;
ivtOffset = 0x1000;
initialLoadSize = 0x2000;
//DCDFilePath = "dcd.bin";
# Note: This is required if the default entrypoint is not the Reset_Handler
# Please set the entryPointAddress to Reset_Handler address
entryPointAddress = 0x60002000;
}

sources {
elfFile = extern(0);
}

section (0)
{
}

Then generate the .sb file, and use the MFGtool download the code, it also works, I also upload the related files for your reference.

For the detail MCUBootUtility reset handler in the IVT issue, I will check internally, it's really the strange issues.

Any updated information, will let you know.

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post