Problems to use MCUXpresso with IMXRT1050-EVBK

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems to use MCUXpresso with IMXRT1050-EVBK

132 Views
carsoftlai
Contributor II

Hello,

I have problems when I try to flash the IMXRT1050-EVBK, after debugging start the LED(D16) just flashing all the time and never stop, until "Terminate" button be clicked, and FW never be update.  I tried couple examples code and I got the same thing.

IDE: MCUXpresso

EVB configuration:
- SW7: 1-off,2-on,3-off,4-on (Hyperflash in Serial Downloader mode)
- In J1, the header is placed on 3,4 (power for the board is supplied via USB at J9)

- In J27, the header is placed on 1,2
- USB cable is connected to J28
- USB cable is connected to J9

pastedImage_1.png

One more question: Can I use 512KB SRAM/TCM instead of external flash?

Thanks, 

Carsoft

Labels (1)
1 Reply

55 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Carsoft Lai,

Thank you for your interest in NXP Semiconductor products and
for the opportunity to serve you.
Q1) Please set SW7 ( 1-off,2-on,3-on,4-off) to assure boot from Hyper Flash.
Q2) Can I use 512KB SRAM/TCM instead of external flash?
-- Yes, you can, however, you need to remove the flash, then move SRAM_ITC up to the top as the Fig 1 illustrates.

pastedImage_8.png

Fig 1

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------