NXP MIMXRT685-EVK i.MX RT600 Evaluation Kit Getting Started Step3. Build, Run failed issue.

cancel
Showing results for 
Search instead for 
Did you mean: 

NXP MIMXRT685-EVK i.MX RT600 Evaluation Kit Getting Started Step3. Build, Run failed issue.

Jump to solution
769 Views
KennyHo
Contributor II

Hello NXP experts:

I had followed NXP MIMXRT685-EVK: i.MX RT600 Evaluation Kit Getting Started Step3. Build, Run,

and met the condition that a pop up message box:
title: "J-Link V6.86f Error",
content: Could not find script file referenced by debugger: D:\McuExpressoWorkSpace\.mcuxpressoide_packages_support\MIMXRT685S_support/Script/evkmimxrt685.JLinkScript Proper functionality cannot be guaranteed.

After setting the "Enable discovering of SEGGER J-Link IP Probes" in Window > Preferences > MCUXpresso IDE > Debug Options > J-Link Options, it still can't solve the issue.

Environment:

OS: Windows7 64 bit professional (Traditional Chinese)
MCUXpresso IDE v11.2.1_4149 windows version
JLink_Windows_V686f.exe

Ask for application advice sincerely.

0 Kudos
1 Solution
749 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @KennyHo,

I think this is related to the version of the J-Link that is flashed in the onboard debugger. Please follow the instructions in this post. To set the EVK to DFU mode short JP1.

Best Regards,
Alexis Andalon

View solution in original post

2 Replies
750 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello @KennyHo,

I think this is related to the version of the J-Link that is flashed in the onboard debugger. Please follow the instructions in this post. To set the EVK to DFU mode short JP1.

Best Regards,
Alexis Andalon

738 Views
KennyHo
Contributor II

Thanks for your help.

By the way,

Working tools combination:

MCUXpressoIDE_11.2.1_4149.exe

JLink_Windows_V686f.exe

LPCScrypt_2.1.1_15.exe

   \LPCScrypt\probe_firmware\LPCLink2\Firmware_JLink_LPC-Link2_20190404.bin

   \LPCScrypt\probe_firmware\LPCXpressoV2\Firmware_JLink_LPCXpressoV2_20190404.bin

SDK_2.8.2_EVK-MIMXRT685.zip

0 Kudos