MIMXRT1064-EVK + AW-AM510-uSD: wifi_init failed

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MIMXRT1064-EVK + AW-AM510-uSD: wifi_init failed

3,370 Views
sandeep_arm
Contributor I

Hi, I'm trying to use the "wifi iperf demo" with an MIMXRT1064-EVK + AW-AM510-uSD board. By following the instructions from https://www.nxp.com/document/guide/getting-started-with-nxp-wi-fi-modules-using-i-mx-rt-platform:GS-...

However, I get the following error when running the example with the WIFI_BOARD_AW_AM457 define set:

 

========================================
wifi iperf demo
========================================
Initialize WLAN Driver
[wifi_io] Error: Error in wlan_card_status()
[wifi_io] Error: Card timeout wlan_download_normal_fw:361
[wifi] Error: sd_wifi_init failed. status code -1
[wlcm] Error: wifi_init failed. status code -1
ASSERT ERROR " WM_SUCCESS == result ": file ".main.c" Line "878" function name "task_main"

 

 

I have the jumpers configured as per the IW416 flow. It's also not clear if the WIFI_BOARD_AW_AM457 should also be used with AW-AM510-uSD modules.

Any suggestions?

0 Kudos
9 Replies

3,250 Views
jc_pacheco
NXP Employee
NXP Employee

Great news!!

Well, the section 1.2 from that guide is referring to the AW-AM457 as an example because there are several modules, we can't include them all
The required configuration should be available in each wifi module's user guide (in this case Azurewave's AW-AM510 User Guide).

Please let us know if you have any further question.

0 Kudos

3,241 Views
sandeep_arm
Contributor I

Ok, I still find it confusing as both the AW-AM457-uSD and AW-AM510-uSD are listed under IW416.

Screen Shot 2021-10-04 at 5.14.33 PM.png

 

0 Kudos

3,233 Views
jc_pacheco
NXP Employee
NXP Employee

The AW-AM457 and the AW-AM510 are both based on the IW416 radio, but they use a different package (QFN vs. CSP respectively). From a firmware/driver perspective, there are no differences between these two modules. The difference is on the size of the module (as the CSP package is smaller), and on the price of the module.

0 Kudos

3,268 Views
jc_pacheco
NXP Employee
NXP Employee

Hi Sandeep,

The jumper settings from your RT1064 look correct. I just double checked and corrected the jumper settings from wifi module, please see above. I'm attaching AzureWave AW-AM510-uSD User Guide.

jc_pacheco_1-1633362111176.png

jc_pacheco_4-1633364979730.png

jc_pacheco_5-1633365026521.png

 

There seems to be a problem when trying to download the firmware to wifi module... Could you please double check that the wifi module is correctly connected all the way in the uSD port?

I confirmed this configuration works with the RT1060... I don't have an RT1064 with me but I'll try to get one and test it.

0 Kudos

3,258 Views
sandeep_arm
Contributor I

Hi @jc_pacheco,

Thank you for the updated jumper settings, just set them up on my board and things are now working!

IMG_4178-1.jpg

=======================================
wifi iperf demo
========================================
Initialize WLAN Driver
Setting up new cal data
MAC Address: 48:E7:DA:3C:76:7F 
========================================
For Soft AP demonstration
Start a Soft AP using option "A" in WPA2 security mode from menu
This also starts DHCP Server with IP 192.168.10.1, NETMASK 255.255.255.0
========================================
For Station demonstration
Start an External AP with SSID as "nxp_wifi_demo" in Open mode
Start DHCP Server on External AP
Station network is configured with Dynamic address assignment
Application provides IPerf support
Set IPERF_SERVER_ADDRESS while using as IPerf Client
========================================
  A  Start Soft AP
  S  Stop Soft AP
  s  Start Scan for external APs
  c  Connect to External AP (SSID='nxp_wifi_demo')
  D  Disconnect from External AP
  I  Enable IEEE PS on Station
  i  Disable IEEE PS on Station
  d  Enable Deep sleep on Station
  e  Disable Deep sleep on Station
  p  Print All Network info
  P  Print DHCP Server info
  1  TCP server mode (RX only test)
  2  TCP client mode (TX only test)
  3  TCP client dual mode (TX and RX in parallel)
  4  TCP client tradeoff mode (TX and RX sequentially)
  5  UDP server mode (RX only test)
  6  UDP client mode (TX only test)
  7  UDP client dual mode (TX and RX in parallel)
  8  UDP client tradeoff mode (TX and RX sequentially)
  h  Help (print this menu)
  H  Print extended help
[net] Initialized TCP/IP networking stack
========================================
app_cb: WLAN: received event 10
========================================
app_cb: WLAN initialized
========================================
WLAN Driver Version   : v1.3.r33.p2
WLAN Firmware Version : IW416-V0, RF878X, FP91, 16.91.10.p214, WPA2_CVE_FIX 1, PVE_FIX 1
========================================

 

Will the documentation in section 1.2 of https://www.nxp.com/document/guide/getting-started-with-nxp-wi-fi-modules-using-i-mx-rt-platform:GS-... - be updated accordingly?

0 Kudos

3,309 Views
jc_pacheco
NXP Employee
NXP Employee

Hi @sandeep_arm ,

I hope you are doing well. Could you please provide an image of your setup (i.MX RT1064-EVK and IW-AM510-uSD module) so we can look at all jumper configurations?

For IW-AM510-uSD, make sure jumpers are set as follow:

jc_pacheco_3-1633364918902.png

Depending on the module and application the EVK might require external power supply to support the initialization current peaks required by the module. Make sure the EVK is powered by external power supply using J2 barrel connector and J1[1-2] configuration.

 

Regards,
JC

0 Kudos

3,277 Views
sandeep_arm
Contributor I

Hi @jc_pacheco ,

Please see the attached photo:

 IMG_4177-1.jpg

Thank you for sharing the jumper settings of the IW-AM510-uSD module, I've set up mine the same way as you shared and also attached a external 5V power supply as you suggested. However, I am still getting the initializatnion error:

========================================
wifi iperf demo
========================================
Initialize WLAN Driver
[wifi_io] Error: Error in wlan_card_status()
[wifi_io] Error: Card timeout wlan_download_normal_fw:361
[wifi] Error: sd_wifi_init failed. status code -1
[wlcm] Error: wifi_init failed. status code -1
ASSERT ERROR " WM_SUCCESS == result ": file ".main.c" Line "878" function name "task_main"
0 Kudos

3,328 Views
sandeep_arm
Contributor I

Hi @estephania_mart,

Thank you for the reply!

I'm using v2.10.0 of the SDK_2.x_EVK-MIMRT1064, and installed in using the MCUXpressoIDE:

 

Screen Shot 2021-09-29 at 9.34.32 AM.png

 

Is there a newer version available in the SDK builder?

 

Thanks,

Sandeep

0 Kudos

3,333 Views
estephania_mart
NXP TechSupport
NXP TechSupport

Hello,

 

Could you please help me with the SDK version you are using ?  Could you please help me confirm you are using the latest SDK available in the SDK builder?

 

Regards,
Estephania

0 Kudos