MIMXRT1060-EVK board

Showing results for 
Search instead for 
Did you mean: 

MIMXRT1060-EVK board

Contributor I


I bought a MIMXRT1060-EVK board and I can not find the iMXRT1060 SDK. I

tried using the iMXRT1050 SDK but all the MCUXpresso IDE v10.2.1_795 demo

would not down load. I tried the IAR demo and I am able to down load

demos. But all the demo that use the sensor (ecompass) on the board fail.

Were can I down the SDK for the iMXRT1060

Thank you



0 Kudos
4 Replies

Contributor IV


Keil MDK has an ecompass example for the i.MX RT1050 board but not the RT1060 board.

I have tried this on the RT1050 board and it works properly.

Since the Keil examples can use the Flash devices or RAM to store the program and this is easily selected - maybe you can try the RT1050 on the RT1060 board assuming you have the chip populated.

Keil MDK is free up to 32K:  MDK-ARM Version 5.26 Evaluation Software Request 

I am working on a tutorial for the RT1050.


Bob Boys

Arm Keil

0 Kudos

Contributor III

Hi Bob,

We are trying to use the Keil MDK5 evaluation version to program and debug the HyperFlash on the RT1050EVKB development board using the JTAG/SW J21 connector.  Will this work or is the only method using the DAP-LINK connector J28?

We have run into memory verification errors when erasing and programming using the JTAG/SW connector. It seems to go through all the steps correctly but then has verification errors at multiple flash locations.  Do you know what the max clock rate for the SW Port should be? We have run into various error messages with different rates.


Mike Bleecker

0 Kudos

NXP Employee
NXP Employee

Hi Daniel,

The SDK for MIMXRT1060-EVK board could be built and downloaded from the “MCUXpresso SDK Builder” webpage at the following link:


RT1060 SDK.png

Regarding trying to download SDK examples from RT1050 on RT1060 board, the download issues are mainly caused because on RT1050 board, the default flash option is the HyperFlash, while on RT1060 board, the default flash option is the QSPI Flash.

Finally, regarding ecompass failure, please ensure that U32 is populated, as RT1060 board does not include this IC by factory.

Hope this will be useful for you.
Best regards!
Note: If this post answers your question, please click the Correct Answer button. Thank you!

0 Kudos

Contributor II

Hi Carlos:

I read and I verify that RT1060 was with Hypeflash NO QSPI, if you verify the resistor position.

Then the problem is with SDK, that come QSPI Flash file (MIMXRT1060_SFDP_QSPI.cfx)  but not Hyperflash file configuration and it's not compatible with RT1050.

Where it is possible to get the file?

Joan De La Torre

0 Kudos