MCUXpresso and RT1050 QSPI Flash Programming

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso and RT1050 QSPI Flash Programming

2,151 Views
Contributor IV

Hello I am using MCUXpresso IDE, version v10.1.0 [Build 589] [2017-11-14] with an MIMXRT1050-EVK SDK, version  2.3.0 (2017-11-16).  It appears that the only available Flash driver for the MIMXRT1050-EVK is MIMXRT1050-EVK_S26KS512S.cfx.

My questions are:

1) I assume this means that I can only program the on-board HyperFlash at this time?

2) When will a QSPI Flash driver for the on-board IS25WP064 become available?

3) When will a QSPI Flash demo, similar to the hello_world_xip become available?

Thanks.

P.S. Here is a list of available flash drivers:

FTFA_1K.cfx                 LPC175x_6x_512.cfx
FTFA_1K_Tiny.cfx            LPC175x_6x_64.cfx
FTFA_2K.cfx                 LPC177x_8x_407x_8x_128.cfx
FTFA_2K_KL28.cfx            LPC177x_8x_407x_8x_256.cfx
FTFA_4K.cfx                 LPC177x_8x_407x_8x_512.cfx
FTFA_KM.cfx                 LPC18_43_Diolan_S29AL016J70T.cfx
FTFE_2K.cfx                 LPC18_43_SPIFI_GENERIC.cfx
FTFE_2K_K32W0x_cm0plus.cfx  LPC18x2_43x2_512.cfx
FTFE_2K_KE.cfx              LPC18x3_43x3_2x256_BootA.cfx
FTFE_4K.cfx                 LPC18x3_43x3_2x256_BootB.cfx
FTFE_4K_K32W0x_cm4.cfx      LPC18x5_43x5_2x384_BootA.cfx
FTFE_8K.cfx                 LPC18x5_43x5_2x384_BootB.cfx
FTFE_8K_KV.cfx              LPC18x7_43x7_2x512_BootA.cfx
FTFL_1K.cfx                 LPC18x7_43x7_2x512_BootB.cfx
FTFL_2K.cfx                 LPC40xx_SPIFI_GENERIC.cfx
LPC11_12_13_128K_8K.cfx     LPC51U6x_256K.cfx
LPC11_12_13_16K_2K.cfx      LPC540xx_SPIFI_GENERIC.cfx
LPC11_12_13_24K_4K.cfx      LPC5410x_256K.cfx
LPC11_12_13_32K_2K.cfx      LPC5410x_512K.cfx
LPC11_12_13_32K_4K.cfx      LPC5411x_128K.cfx
LPC11_12_13_32K_8K.cfx      LPC5411x_256K.cfx
LPC11_12_13_40K_8K.cfx      LPC5460x_256K.cfx
LPC11_12_13_48K_4K.cfx      LPC5460x_512K.cfx
LPC11_12_13_48K_8K.cfx      LPC5460x_SPIFI_GENERIC.cfx
LPC11_12_13_4K_1K.cfx       LPC800_16.cfx
LPC11_12_13_56K_8K.cfx      LPC800_32.cfx
LPC11_12_13_64K_8K.cfx      LPC800_4.cfx
LPC11_12_13_80K_8K.cfx      LPC800_8.cfx
LPC11_12_13_8K_2K.cfx       LPC80x_16.cfx
LPC11_12_13_96K_8K.cfx      LPC84x_64.cfx
LPC11U6x_128K.cfx           LPC8N0x_30K.cfx
LPC11U6x_256K.cfx           MIMXRT1050-EVK_S26KS512S.cfx
LPC11U6x_64K.cfx            PN7xxxxx_154k.cfx
LPC15xx_128K.cfx            PN7xxxxx_158k.cfx
LPC15xx_256K.cfx            PN7xxxxx_80k.cfx
LPC15xx_64K.cfx             PN7xxxxx_EE_3_5k.cfx
LPC175x_6x_128.cfx          SST39VF3201B_Hitex_LPC1850A_4350A.cfx
LPC175x_6x_256.cfx          SST39VF3201x_Hitex_LPC1850A_4350A.cfx
LPC175x_6x_32.cfx‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍
Labels (1)
0 Kudos
6 Replies

170 Views
Contributor III

Hello Ryan,

Have you had any updates in this area? We are at the point of testing out XiP projects on the quad spi flash included on the MIMXRT1050EVK and my sample project is throwing chip init fail errors upon starting a debug session (details below). I'm attempting to run from flash using the LPC5460x_SPIFI_GENERIC.cfx driver. The MIMXRT1050-EVK_S26KS512S.cfx was working for the hyperflash unit that we subsequently took off our board in order to test out the quadspi flash.

With the LPC5460x_SPIFI_GENERIC.cfx driver we're getting the following debug errors.

vendor chip initialization failed - Em(17). Debug port inaccessible after access at location 0x2000B728
vendor chip initialization failed - Em(17). Debug port inaccessible after access at location 0x2000B728
03: Failed on chip setup
Invalid part, XML, or configuration.
Debugging context: evkmimxrt1050_demo_apps_hello_world_xip LinkServer Debug

Error in final launch sequence
Failed to execute MI command:
-target-select extended-remote | crt_emu_cm_redlink -msg-port=60146 -g -mi -2 -pMIMXRT1052xxxxx -vendor=NXP --no-packed --cachelib libm7_cache.so -reset= -ProbeHandle=1 -CoreIndex=0 -cache=disable -x C:/Users/Edw/Documents/MCUXpressoIDE_10.1.1_606/workspace/evkmimxrt1050_demo_apps_hello_world_xip/Debug --flash-dir C:/Users/Edw/mcuxpresso/01/.mcuxpressoide_packages_support/MIMXRT1052xxxxx_support/Flash --telnet 3330
Error message from debugger back end:
Remote communication error. Target disconnected.: No error.
Remote communication error. Target disconnected.: No error.

I saw some other community posts that suggest using the flashloader however I was curious if there is a method for using the MCUXpresso IDE to debug in place?

170 Views
Contributor IV

Thanks for the update Ed.

0 Kudos

170 Views
Contributor IV

FYI, Digikey and Mouser are listing the QSPI Flash part on the MIMXRT1050-EVK as obsolete.  Perhaps this is why there is no news of drivers.

0 Kudos

170 Views
NXP Employee
NXP Employee

Hi,

you can download the Flashloader for i.MXRT1050 which supports QSPI NOR Flash here:

www.nxp.com/imxrt1050 > Software & Tools > Flashloader i.MX-RT1050 (REV 1.0) and consider what is mentioned here https://community.nxp.com/thread/464993 

By now we dont have information about when QSPI driver is being developed.


Regards,
Carlos

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

170 Views
Contributor IV

Sorry, I missed the "By now we don't have information about when QSPI driver is being developed." line.  This is unfortunate, we were hoping to be able to develop and debug with QSPI Flash from the IDE.

0 Kudos

170 Views
Contributor IV

Hello Carlos, thanks for the reply.  I have the flash loader.  What I am asking is how I can do this from the MCUXpresso IDE.  That is build, program QSPI Flash and debug code the same way I can with HyperFlash. 

Are you suggesting that the only way to work with QSPI Flash is through the MfgTool (FlashLoader)?

0 Kudos