MCUXpresso 11.1 SDK java null pointer exception

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso 11.1 SDK java null pointer exception

256 Views
anujtanksali
Contributor II

Hello.

I am using MCUXpresso 10.3 with SDK version 2.4 for development on iMXRT-1064 EVK board

I was able to add driver and other components through SDK Management menu. 

Recently i updated to MCUXpresso 11.1 with SDK version 2.61 as i don't think 2.4 version is compatible with MCUXpresso 10.3 version.

Using MCUXpresso 11.1 and SDK version 2.6.1 my project compiles ok but when i try to add any driver component through SDK Management menu then i get a Java Null pointer exception error. Please see the attached images and details of error in text file.

Can you please help me out to resolve the issue.

Regards,

Anuj

Labels (1)
Tags (1)
0 Kudos
4 Replies

127 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello, Anuj 

I wasn't able to reproduce the behavior that you are mentioning. I took the iled_blinky from the SDK as a base and I added a couple of drivers with the SDK management and I was able to compile without problems. Could you please provide a step-by-step guide on how to reproduce the behavior?

Once you installed version 2.6.1 of the SDK, did you uninstall the previous versions? If no, could you please try doing this to see if this solves the behavior?

Regards, 

Victor 

0 Kudos

127 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello, Anuj 

 

Additional to what I mentioned, I would recommend you download the newest version of the SDK (2.7.0) which was released a couple of days ago. 

 

Regards, 

Victor 

0 Kudos

127 Views
anujtanksali
Contributor II

Hello,

Thanks for the reply.

Yes if i use any example projects for the EVK board 1064 and then add drivers i too am able to add them without any error.

I have not uninstalled the previous versions. Will uninstall the previous versions and check.

This issue is observed for a specific project only. I have a previous workspace on MCUXpresso 10.3 and am able to add drivers through SDK. But if i import the same project into MCUXpresso 11.1 workspace then this issue is observed.

How do i resolve this issue?. I think creating a new project and adding the files again would resolve the issue. Is there any other way such as resetting the settings to default values?

Regards,

Anuj

0 Kudos

127 Views
victorjimenez
NXP TechSupport
NXP TechSupport

Hello Anuj, 

If the problem is present only in that project what you mentioned is a good way to solve it. You can create a new project in the new IDE version and copy the files from the old version. 

Regards, 

Victor 

0 Kudos