IMXRT1050-EVKB   -  Fatel Error : Failed to connect to CPU Session aborted !   

cancel
Showing results for 
Search instead for 
Did you mean: 

IMXRT1050-EVKB   -  Fatel Error : Failed to connect to CPU Session aborted !   

634 Views
derekchoi
Contributor I

Hi , 

    I have problem with my IMXRT1050-EVKB. It seems that it is easy to have fatal error after programming FW into external flash for several times .   Two boards have been damaged with this error message and I cannot program the flash again.    One board has been modified for booting up from QSPI flash instead of Hyper flash according to Application Note.    Both broads are working fine in the beginning.  Unfortunately there is fatal error after using for some time.    Do anyone have idea about this problem ?   Thanks 

0 Kudos
6 Replies

323 Views
vinaymanikkoth
Contributor II

i am also ran into similar problem. you guys able to solve this ?

0 Kudos

371 Views
derekchoi
Contributor I

Hi jeremyzhou,

       Thanks for your prompt response.  Please find the log and the captured screen of IDE when the problem happened.  I have tried to run on RAM , the same error message appeared.   Actually, I am not sure what steps I have done before I was dead. I just plug and unplug the USB cable a few times and run some different examples from SDK.   As I mentioned prerviously I have another MIXRT1050-EVKB which have been modified to work with QSPI flash instead according to the application note.   The same problem happened.  

       Thanks again for your help ! 

Regards,


Derek 

hello_world_Fatal_error.png

0 Kudos

371 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Derek Choi,

Thanks for your reply.
I'd like to suggest you try the below steps to fix the issue.
1. Please refer to the attachment to update the firmware of on-board debugger and give a debug later.

OpenSDA Serial and Debug Adapter | NXP 
2. If it still not work, set the boot mode to Serial Downloader, then give a debug again.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

371 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi Derek Choi,

Thank you for your interest in NXP Semiconductor products and
the opportunity to serve you.
According to your description, whether you mean that on-board Hyper flash S26KS512SDPBHI02 would become damaged after severals programming operation, it seems a weird, as I've never encountered this kind of phenomenon before, on my MIMXRT1050 board, the Hyper flash work well even if be programmed a lot of times.
So I'd like to you to run the hyper_flash which is from the SDK library in internal RAM to verify the Hyper flash work well or not, in further, please share the error message the IDE will provide when you try to debug the 'damaged' MIMXRT1050.

Have a great day,
TIC

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

371 Views
derekchoi
Contributor I

Hi jeremyzhou,

     Thanks for your prompt reply.   Please find the log message below :

oct 15/10:49:23.550 DEBUG2 :

StartSession()

oct 15/10:49:23.550 INFO : Debug Log(info): Loading the CMSIS-DAP driver
oct 15/10:49:23.553 DEBUG2 : -> ConnectToHardware()
oct 15/10:49:23.553 DEBUG2 : -> CreateJetTerminal()
oct 15/10:49:23.553 DEBUG2 : <- CreateJetTerminal()
oct 15/10:49:23.553 DEBUG2 : -> AcquireSigAPIPtr()
oct 15/10:49:23.553 DEBUG2 : SigAPISetPath('C:\Program Files (x86)\IAR Systems\Embedded Workbench 8.3\arm\bin\jet\bin')
oct 15/10:49:23.559 DEBUG2 : <- AcquireSigAPIPtr()
oct 15/10:49:23.559 DEBUG2 : -> AcquireSigProbe()
oct 15/10:49:23.561 DEBUG2 : SigProbe version: 1.17
oct 15/10:49:23.561 DEBUG2 : <- AcquireSigProbe()
oct 15/10:49:23.561 DEBUG2 : -> SigProbeInit()
oct 15/10:49:23.564 INFO : Debug Log(info): Probe: CMSIS-DAP probe SW module ver 1.17

oct 15/10:49:23.564 INFO : Probe: CMSIS-DAP probe SW module ver 1.17

oct 15/10:49:23.564 DEBUG2 : <- SigProbeInit()
oct 15/10:49:23.564 DEBUG2 : -> ConnectToProbe()
oct 15/10:49:23.565 DEBUG2 : ISigProbe::EnumScan()
oct 15/10:49:23.569 DEBUG2 : scanning finished: found 1 probes
oct 15/10:49:23.579 DEBUG2 : connection Serial No: DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900
oct 15/10:49:23.585 DEBUG2 : connection found probes:
oct 15/10:49:23.604 INFO : Debug Log(info): Probe: Connecting to DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900 firmware v.1.10

oct 15/10:49:23.604 INFO : Probe: Connecting to DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900 firmware v.1.10

oct 15/10:49:23.604 DEBUG2 : <- ConnectToProbe()
oct 15/10:49:23.604 DEBUG2 : -> CreateSigEmus()
oct 15/10:49:23.604 DEBUG2 : ISigAPI::CreateInstance('ISigEmu', 'EARM', '')
oct 15/10:49:23.607 DEBUG2 : Core 0: sigEmu->LinkAttach(ISigProbe)
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('Emulator', 'cmsisdap')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('Processor', 'Cortex-M7')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JtagHeader', 'ARM-SWD')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('CoreSightSWJ', 'SWD')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JTagSpeed', 'auto')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BoardCfg', '-auto')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JtagInitDelay', '200,r:300')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BigEndian', '0')
oct 15/10:49:23.607 DEBUG2 : ISigEmu::LinkAttach('SigTerminalLog'...)
oct 15/10:49:23.607 DEBUG2 : Core 0: sigEmu->LinkAttach(SigTerminalLog)
oct 15/10:49:23.607 DEBUG2 : <- CreateSigEmus()
oct 15/10:49:23.607 DEBUG2 : -> CreateInterfaceComProtocol()
oct 15/10:49:23.607 DEBUG2 : ISigProbe::AcquireInterface('ComProtocol')
oct 15/10:49:23.607 DEBUG2 : <- CreateInterfaceComProtocol()
oct 15/10:49:23.607 DEBUG2 : -> CollectCoreNames()
oct 15/10:49:23.607 DEBUG2 : <- CollectCoreNames()
oct 15/10:49:23.607 DEBUG2 : -> DoIceConnect()
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BoardDID', '')
oct 15/10:49:23.607 DEBUG2 : Core 0: IceConnect(...)
oct 15/10:49:23.609 DEBUG2 : <- DoIceConnect()
oct 15/10:49:23.609 DEBUG2 : -> DoIceInit()
oct 15/10:49:23.609 DEBUG2 : Core 0: IceInit(...)
oct 15/10:49:23.618 DEBUG2 : ISigEmu::IceVersion(1c0)
oct 15/10:49:23.618 INFO : Debug Log(info): Emulation layer version 4.48
oct 15/10:49:23.619 DEBUG2 : ISigEmu::IceStatus(0)
oct 15/10:49:23.619 DEBUG2 : <- DoIceInit()
oct 15/10:49:23.619 DEBUG2 : -> CreateCmdInterpreter()
oct 15/10:49:23.619 DEBUG2 : ISigProbe::CreateInstance(..., 'SigCmdInterpreter', '')
oct 15/10:49:23.621 DEBUG2 : ISigCmdInterpreter::LinkAttach('ISigEmu',...)
oct 15/10:49:23.621 DEBUG2 : <- CreateCmdInterpreter()
oct 15/10:49:23.621 DEBUG2 : -> AcquireA2DInterface()
oct 15/10:49:23.621 DEBUG2 : ISigProbe::AcquireInterface('ISigA2D')
oct 15/10:49:23.621 ERROR : ConnectToHardware(): Failed to create sigA2D object
oct 15/10:49:23.837 INFO : Debug Log(info): Notification to init-after-power-up hookup.

oct 15/10:49:23.837 INFO : Notification to init-after-power-up hookup.

oct 15/10:49:23.837 DEBUG2 : <Call to _ExecDeviceProbeConnect: macro undefined
oct 15/10:49:23.838 DEBUG2 : <Call to execUserProbeConnect: macro undefined
oct 15/10:49:23.838 INFO : Debug Log(info): Notification to core-connect hookup.

oct 15/10:49:23.838 INFO : Notification to core-connect hookup.

oct 15/10:49:23.838 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.838 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.841 INFO : Debug Log(info): Connected DAP v1 on SWD. Detected IDCODE=0xbd11477.

oct 15/10:49:23.841 INFO : Connected DAP v1 on SWD. Detected IDCODE=0xbd11477.

oct 15/10:49:23.855 INFO : Debug Log(info): CoreSight error: Cannot read DP STAT register. No DAP access. Debugging is not possible.

oct 15/10:49:23.855 INFO : CoreSight error: Cannot read DP STAT register. No DAP access. Debugging is not possible.

oct 15/10:49:23.856 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.856 INFO : Debug Log(info): CPU status FAILED
oct 15/10:49:23.871 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.871 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.889 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.905 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.905 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.909 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.909 DEBUG2 : <- AcquireA2DInterface()
oct 15/10:49:23.909 DEBUG2 : -> AcquireEmuVectInterface()
oct 15/10:49:23.909 DEBUG2 : ISigEmu::AcquireInterface('ISigEmuVect') (core 0)
oct 15/10:49:23.910 DEBUG2 : <- AcquireEmuVectInterface()
oct 15/10:49:23.910 DEBUG2 : -> AcquireEmuWptInterface()
oct 15/10:49:23.910 DEBUG2 : ISigEmu::AcquireInterface('ISigEmuWpt')
oct 15/10:49:23.910 DEBUG2 : <- AcquireEmuWptInterface()
oct 15/10:49:23.910 DEBUG2 : -> AcquirePcSamplerInterface()
oct 15/10:49:23.910 DEBUG2 : ISigEmu::AcquireInterface('ISigPcSampler')
oct 15/10:49:23.937 DEBUG2 : <- AcquirePcSamplerInterface()
oct 15/10:49:23.938 DEBUG2 : <- ConnectToHardware()
oct 15/10:49:23.938 DEBUG2 : <Call to _ExecDevicePreReset: macro undefined
oct 15/10:49:23.938 DEBUG2 : <Call to execUserPreReset: macro undefined
oct 15/10:49:23.938 DEBUG2 : -> LowLevelReset(system, delay 200)
oct 15/10:49:23.938 INFO : Debug Log(info): LowLevelReset(system, delay 200)
oct 15/10:49:23.938 DEBUG2 : core 0: IsigEmu::ParamSet('JtagInitDelay', '200,r:300')
oct 15/10:49:23.938 DEBUG2 : core 0: IsigEmu::ParamSet('ResetStyle', 'SYSTEM')
oct 15/10:49:23.938 DEBUG2 : Core 0: system reset
oct 15/10:49:24.191 DEBUG2 : -> LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.208 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.208 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.212 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.228 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.228 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.232 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.248 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.248 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.266 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.266 DEBUG2 : <- LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.467 DEBUG2 : -> LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.483 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.483 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.487 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.503 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.503 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.507 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.523 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.523 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.527 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.527 DEBUG2 : <- LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.527 ERROR : LowLevelReset() returned Failure while executing the operation
oct 15/10:49:24.527 DEBUG2 : <- LowLevelReset(system, delay 200)
oct 15/10:49:24.527 DEBUG2 : -> StartSession(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.543 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.543 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.561 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.577 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.577 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.581 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.597 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.597 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.615 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.615 DEBUG2 : <- StartSession(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.631 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.631 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.649 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.665 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.665 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.669 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.685 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.685 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.703 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:26.104 INFO : Debug Log(error): Fatal error: Failed to connect to CPU Session aborted!
oct 15/10:49:26.104 DEBUG2 : ********** 'Controlled' exception (1) caught in DbBeginSession
oct 15/10:49:26.169 DEBUG2 : -> AboutToStopSession()
oct 15/10:49:26.186 DEBUG2 : <- AboutToStopSession()
oct 15/10:49:26.243 DEBUG2 : -> PrepareStopSession()
oct 15/10:49:26.243 DEBUG2 : <- PrepareStopSession()
oct 15/10:49:26.266 DEBUG2 : StopGui()
oct 15/10:49:26.286 DEBUG2 : -> StopSession()
oct 15/10:49:26.297 DEBUG2 : -> TerminateHardware()
oct 15/10:49:26.297 DEBUG2 : ISigEmu::ReleaseInterface(sigWpt)
oct 15/10:49:26.297 DEBUG2 : ISigEmu::ReleaseInterface(sigVect)
oct 15/10:49:26.297 DEBUG2 : ISigEmu::IceTerm()
oct 15/10:49:26.307 DEBUG2 : Core 0: sigEmu->LinkAttach(ISigProbe)
oct 15/10:49:26.307 DEBUG2 : ISigApi::ReleaseInstance(sigEmu)
oct 15/10:49:26.309 DEBUG2 : SigAPITerm()
oct 15/10:49:26.310 INFO : Debug Log(info): Cannot initialize DAP access.

oct 15/10:49:26.310 INFO : Cannot initialize DAP access.

oct 15/10:49:26.310 DEBUG2 : <- TerminateHardware()
oct 15/10:49:26.310 DEBUG2 : <- StopSession()
oct 15/10:49:26.310 DEBUG2 : -> ~TdJetDriver()
oct 15/10:49:26.310 DEBUG2 : -> TerminateHardware()
oct 15/10:49:26.310 DEBUG2 : <- TerminateHardware()

hello_world_Fatal_error.png

0 Kudos

371 Views
derekchoi
Contributor I

Hi jeremyzhou,

 

       Thanks for your prompt response.  Please find the log and the captured screen of IDE when the problem happened.  I have tried to run on RAM , the same error message appeared.   Actually, I am not sure what steps I have done before I was dead. I just plug and unplug the USB cable a few times and run some different examples from SDK.   As I mentioned previously I have another MIXRT1050-EVKB which have been modified to work with QSPI flash instead according to the application note.   The same problem happened.  

 

       Thanks again for your help ! 

 

 

Regards,


Derek 

oct 15/10:49:23.550 DEBUG2 :

StartSession()

oct 15/10:49:23.550 INFO : Debug Log(info): Loading the CMSIS-DAP driver
oct 15/10:49:23.553 DEBUG2 : -> ConnectToHardware()
oct 15/10:49:23.553 DEBUG2 : -> CreateJetTerminal()
oct 15/10:49:23.553 DEBUG2 : <- CreateJetTerminal()
oct 15/10:49:23.553 DEBUG2 : -> AcquireSigAPIPtr()
oct 15/10:49:23.553 DEBUG2 : SigAPISetPath('C:\Program Files (x86)\IAR Systems\Embedded Workbench 8.3\arm\bin\jet\bin')
oct 15/10:49:23.559 DEBUG2 : <- AcquireSigAPIPtr()
oct 15/10:49:23.559 DEBUG2 : -> AcquireSigProbe()
oct 15/10:49:23.561 DEBUG2 : SigProbe version: 1.17
oct 15/10:49:23.561 DEBUG2 : <- AcquireSigProbe()
oct 15/10:49:23.561 DEBUG2 : -> SigProbeInit()
oct 15/10:49:23.564 INFO : Debug Log(info): Probe: CMSIS-DAP probe SW module ver 1.17

oct 15/10:49:23.564 INFO : Probe: CMSIS-DAP probe SW module ver 1.17

oct 15/10:49:23.564 DEBUG2 : <- SigProbeInit()
oct 15/10:49:23.564 DEBUG2 : -> ConnectToProbe()
oct 15/10:49:23.565 DEBUG2 : ISigProbe::EnumScan()
oct 15/10:49:23.569 DEBUG2 : scanning finished: found 1 probes
oct 15/10:49:23.579 DEBUG2 : connection Serial No: DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900
oct 15/10:49:23.585 DEBUG2 : connection found probes:
oct 15/10:49:23.604 INFO : Debug Log(info): Probe: Connecting to DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900 firmware v.1.10

oct 15/10:49:23.604 INFO : Probe: Connecting to DAPLink CMSIS-DAP:0227000047784e45000f9004d7450026ddb1000097969900 firmware v.1.10

oct 15/10:49:23.604 DEBUG2 : <- ConnectToProbe()
oct 15/10:49:23.604 DEBUG2 : -> CreateSigEmus()
oct 15/10:49:23.604 DEBUG2 : ISigAPI::CreateInstance('ISigEmu', 'EARM', '')
oct 15/10:49:23.607 DEBUG2 : Core 0: sigEmu->LinkAttach(ISigProbe)
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('Emulator', 'cmsisdap')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('Processor', 'Cortex-M7')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JtagHeader', 'ARM-SWD')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('CoreSightSWJ', 'SWD')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JTagSpeed', 'auto')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BoardCfg', '-auto')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('JtagInitDelay', '200,r:300')
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BigEndian', '0')
oct 15/10:49:23.607 DEBUG2 : ISigEmu::LinkAttach('SigTerminalLog'...)
oct 15/10:49:23.607 DEBUG2 : Core 0: sigEmu->LinkAttach(SigTerminalLog)
oct 15/10:49:23.607 DEBUG2 : <- CreateSigEmus()
oct 15/10:49:23.607 DEBUG2 : -> CreateInterfaceComProtocol()
oct 15/10:49:23.607 DEBUG2 : ISigProbe::AcquireInterface('ComProtocol')
oct 15/10:49:23.607 DEBUG2 : <- CreateInterfaceComProtocol()
oct 15/10:49:23.607 DEBUG2 : -> CollectCoreNames()
oct 15/10:49:23.607 DEBUG2 : <- CollectCoreNames()
oct 15/10:49:23.607 DEBUG2 : -> DoIceConnect()
oct 15/10:49:23.607 DEBUG2 : core 0: IsigEmu::ParamSet('BoardDID', '')
oct 15/10:49:23.607 DEBUG2 : Core 0: IceConnect(...)
oct 15/10:49:23.609 DEBUG2 : <- DoIceConnect()
oct 15/10:49:23.609 DEBUG2 : -> DoIceInit()
oct 15/10:49:23.609 DEBUG2 : Core 0: IceInit(...)
oct 15/10:49:23.618 DEBUG2 : ISigEmu::IceVersion(1c0)
oct 15/10:49:23.618 INFO : Debug Log(info): Emulation layer version 4.48
oct 15/10:49:23.619 DEBUG2 : ISigEmu::IceStatus(0)
oct 15/10:49:23.619 DEBUG2 : <- DoIceInit()
oct 15/10:49:23.619 DEBUG2 : -> CreateCmdInterpreter()
oct 15/10:49:23.619 DEBUG2 : ISigProbe::CreateInstance(..., 'SigCmdInterpreter', '')
oct 15/10:49:23.621 DEBUG2 : ISigCmdInterpreter::LinkAttach('ISigEmu',...)
oct 15/10:49:23.621 DEBUG2 : <- CreateCmdInterpreter()
oct 15/10:49:23.621 DEBUG2 : -> AcquireA2DInterface()
oct 15/10:49:23.621 DEBUG2 : ISigProbe::AcquireInterface('ISigA2D')
oct 15/10:49:23.621 ERROR : ConnectToHardware(): Failed to create sigA2D object
oct 15/10:49:23.837 INFO : Debug Log(info): Notification to init-after-power-up hookup.

oct 15/10:49:23.837 INFO : Notification to init-after-power-up hookup.

oct 15/10:49:23.837 DEBUG2 : <Call to _ExecDeviceProbeConnect: macro undefined
oct 15/10:49:23.838 DEBUG2 : <Call to execUserProbeConnect: macro undefined
oct 15/10:49:23.838 INFO : Debug Log(info): Notification to core-connect hookup.

oct 15/10:49:23.838 INFO : Notification to core-connect hookup.

oct 15/10:49:23.838 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.838 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.841 INFO : Debug Log(info): Connected DAP v1 on SWD. Detected IDCODE=0xbd11477.

oct 15/10:49:23.841 INFO : Connected DAP v1 on SWD. Detected IDCODE=0xbd11477.

oct 15/10:49:23.855 INFO : Debug Log(info): CoreSight error: Cannot read DP STAT register. No DAP access. Debugging is not possible.

oct 15/10:49:23.855 INFO : CoreSight error: Cannot read DP STAT register. No DAP access. Debugging is not possible.

oct 15/10:49:23.856 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.856 INFO : Debug Log(info): CPU status FAILED
oct 15/10:49:23.871 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.871 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.889 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.905 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:23.905 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:23.909 DEBUG2 : ConnectToHardware(), checking status (#1): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:23.909 DEBUG2 : <- AcquireA2DInterface()
oct 15/10:49:23.909 DEBUG2 : -> AcquireEmuVectInterface()
oct 15/10:49:23.909 DEBUG2 : ISigEmu::AcquireInterface('ISigEmuVect') (core 0)
oct 15/10:49:23.910 DEBUG2 : <- AcquireEmuVectInterface()
oct 15/10:49:23.910 DEBUG2 : -> AcquireEmuWptInterface()
oct 15/10:49:23.910 DEBUG2 : ISigEmu::AcquireInterface('ISigEmuWpt')
oct 15/10:49:23.910 DEBUG2 : <- AcquireEmuWptInterface()
oct 15/10:49:23.910 DEBUG2 : -> AcquirePcSamplerInterface()
oct 15/10:49:23.910 DEBUG2 : ISigEmu::AcquireInterface('ISigPcSampler')
oct 15/10:49:23.937 DEBUG2 : <- AcquirePcSamplerInterface()
oct 15/10:49:23.938 DEBUG2 : <- ConnectToHardware()
oct 15/10:49:23.938 DEBUG2 : <Call to _ExecDevicePreReset: macro undefined
oct 15/10:49:23.938 DEBUG2 : <Call to execUserPreReset: macro undefined
oct 15/10:49:23.938 DEBUG2 : -> LowLevelReset(system, delay 200)
oct 15/10:49:23.938 INFO : Debug Log(info): LowLevelReset(system, delay 200)
oct 15/10:49:23.938 DEBUG2 : core 0: IsigEmu::ParamSet('JtagInitDelay', '200,r:300')
oct 15/10:49:23.938 DEBUG2 : core 0: IsigEmu::ParamSet('ResetStyle', 'SYSTEM')
oct 15/10:49:23.938 DEBUG2 : Core 0: system reset
oct 15/10:49:24.191 DEBUG2 : -> LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.208 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.208 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.212 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.228 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.228 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.232 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.248 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.248 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.266 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.266 DEBUG2 : <- LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.467 DEBUG2 : -> LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.483 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.483 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.487 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.503 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.503 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.507 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.523 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.523 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.527 DEBUG2 : LowLevelReset(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.527 DEBUG2 : <- LowLevelReset(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.527 ERROR : LowLevelReset() returned Failure while executing the operation
oct 15/10:49:24.527 DEBUG2 : <- LowLevelReset(system, delay 200)
oct 15/10:49:24.527 DEBUG2 : -> StartSession(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.543 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.543 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.561 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.577 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.577 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.581 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.597 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.597 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.615 DEBUG2 : StartSession(): Core 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.615 DEBUG2 : <- StartSession(): WaitForCpuResetToComplete(core 0)
oct 15/10:49:24.631 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.631 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.649 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.665 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.665 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.669 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:24.685 DEBUG2 : <Call to _ExecDeviceCoreConnect: macro undefined
oct 15/10:49:24.685 DEBUG2 : <Call to execUserCoreConnect: macro undefined
oct 15/10:49:24.703 DEBUG2 : StartSession() checking powerCore 0: CpuStatus(status = <0x80: CPU_STATUS_MERR>) = 0
oct 15/10:49:26.104 INFO : Debug Log(error): Fatal error: Failed to connect to CPU Session aborted!
oct 15/10:49:26.104 DEBUG2 : ********** 'Controlled' exception (1) caught in DbBeginSession
oct 15/10:49:26.169 DEBUG2 : -> AboutToStopSession()
oct 15/10:49:26.186 DEBUG2 : <- AboutToStopSession()
oct 15/10:49:26.243 DEBUG2 : -> PrepareStopSession()
oct 15/10:49:26.243 DEBUG2 : <- PrepareStopSession()
oct 15/10:49:26.266 DEBUG2 : StopGui()
oct 15/10:49:26.286 DEBUG2 : -> StopSession()
oct 15/10:49:26.297 DEBUG2 : -> TerminateHardware()
oct 15/10:49:26.297 DEBUG2 : ISigEmu::ReleaseInterface(sigWpt)
oct 15/10:49:26.297 DEBUG2 : ISigEmu::ReleaseInterface(sigVect)
oct 15/10:49:26.297 DEBUG2 : ISigEmu::IceTerm()
oct 15/10:49:26.307 DEBUG2 : Core 0: sigEmu->LinkAttach(ISigProbe)
oct 15/10:49:26.307 DEBUG2 : ISigApi::ReleaseInstance(sigEmu)
oct 15/10:49:26.309 DEBUG2 : SigAPITerm()
oct 15/10:49:26.310 INFO : Debug Log(info): Cannot initialize DAP access.

oct 15/10:49:26.310 INFO : Cannot initialize DAP access.

oct 15/10:49:26.310 DEBUG2 : <- TerminateHardware()
oct 15/10:49:26.310 DEBUG2 : <- StopSession()
oct 15/10:49:26.310 DEBUG2 : -> ~TdJetDriver()
oct 15/10:49:26.310 DEBUG2 : -> TerminateHardware()
oct 15/10:49:26.310 DEBUG2 : <- TerminateHardware()

0 Kudos