How to update SDK to make Free Master protocol V4 recorder work?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to update SDK to make Free Master protocol V4 recorder work?

Jump to solution
176 Views
Contributor III

Before I update it to the newest version of the SDK, my application work correctly with FreeMaster over CAN at 1MHz, but FM recorder sometimes does not work because my FM drive does not support protocol V4. 

So that I imported all FM components in SDK 2.8.2 to my application, it takes several times to get compiler pass. There is no detailed manual or API document to help me how to update SDK FM component.  I tried to import a few components in SDK, but which parts, CAN, FlexCAN, Protocol, cfg or more? The compiler always find more and more errors and fail to compile. I have to important all FM components in new SDK to let compiler to pass compiling, but new code does not talk, the peripheral settings of FlexCAN are the same as my work code, is there any extra setting needed for protocol V4? Is a new Clock initialization code needed or special order of initialization of clock sources the involving the other peripherals.

Labels (1)
0 Kudos
1 Solution
163 Views
NXP TechSupport
NXP TechSupport

Hello, 

If you will do the migration of the FM files to the newest SDK then you need to migrate all the SDK files, you cannot use some files from an older version and other files from a newer version. This includes all the drivers, the board files, the cfg files, memory files, startup… Everything that your application is using from the SDK needs to be migrated to the newest version, not only the FM files.

View solution in original post

6 Replies
152 Views
NXP Employee
NXP Employee

Dear customer,

the FreeMASTER driver in SDK 2.8 which is currently available at NXP web site does not yet contain full support of CAN communication for RT105x/6x platforms.

The support for all i.MX-RT platforms should appear in the upcoming version 2.9.

I'm attaching a patch file for the SDK 2.8.2 RT1050 package with the new CAN (and USB) examples in the boards/evkbimxrt1050 folder. There are also some minor fixes made in the common part of the FreeMASTER driver in the src folder. Please apply the patch to your SDK package and test the fmstr_can demo application using the EVKB-IMXRT1050 evaluation board.

Let me know if it works properly on your side. I'm able to generate a similar patch for other i.MX-RT boards in case you need it.

Thanks,
Michal

115 Views
Contributor III

Hi, Michal:

 I use MCUXpresso IDE, it does not accept the patch zip file in my SDK installation section when I drag and drop it; MCUXpresso cannot find and open your project, that are for Armgcc, IAR and MDK so that I cannot test this patch and run the fmstr_can example demo, am I go it right? I got reminder today to update to SDK 2.8.4, is it cantain full support of CAN for protocol V4? If not, I'd rather wait for SDK 2.9 release!

Thank you for help!

Jian

 

 

 

 

  

0 Kudos
105 Views
NXP Employee
NXP Employee

Hello Jian,

I'm afraid that 2.8.4 also does not have the FreeMASTER CAN demo. The ZIP that I sent only contained a source files that you can use in your project - please copy them manually to your created project or over another demo (e.g. fmstr_uart).

The 2.9 is going to have the CAN demo included by default. So if you can wait for it, it is a better option.

Regards,
Michal

0 Kudos
141 Views
Contributor III

Hi, Michael:

Many thanks for help and patch file, I will try you suggest and let you know the ourcome!

Jamesli

 

0 Kudos
164 Views
NXP TechSupport
NXP TechSupport

Hello, 

If you will do the migration of the FM files to the newest SDK then you need to migrate all the SDK files, you cannot use some files from an older version and other files from a newer version. This includes all the drivers, the board files, the cfg files, memory files, startup… Everything that your application is using from the SDK needs to be migrated to the newest version, not only the FM files.

View solution in original post

142 Views
Contributor III

Hi, Victor: 

Thank you for help. Yes, I have to update all file in SDK and otherwise, it cannot pass compiling.

 

 

0 Kudos