Firmware download with NXP MCU Boot Uility

cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware download with NXP MCU Boot Uility

Jump to solution
200 Views
emdev
Contributor III

Dear all,

Thanks for your help.

When I download firmware to board, there are below pop up messages.

"Invalid vector address found in image file:" in my file(srec).

I used axf file and NXP MCU Boot Utility changes it to SREC file.

I modify and add some codes which are based on evkmimxrt1010_freertos_hello.

But there is no problem and I can download images well with original codes which is evkmimxrt1010_freertos_hello and there is no changes.

Would you tell me what must I should check it?

Thanks.

Labels (1)
0 Kudos
1 Solution
141 Views
emdev
Contributor III

Dear Jay,

To convert axf to srec, NXP MCU Boot Utility uses iar_ewarm.

I think it is cause of problem but I don't know exact cause of problem.

I checked below link and can change axf to srec when I build images.

https://mcuoneclipse.com/2017/03/29/mcuxpresso-ide-s-record-intel-hex-and-binary-files/

With srec file which are made when image is built, there is no problem and it works well.

Thanks.

View solution in original post

0 Kudos
4 Replies
193 Views
jay_heng
NXP Employee
NXP Employee

Each example in SDK has many different builds, the default build (Debug/Release) is linked from start of ITCM RAM, this is only used for online debugging.

For offline boot, you need to switch to XIP builds or ram_0x1400 build, then you can flash these images by NXP MCU Boot Utility

 

0 Kudos
176 Views
emdev
Contributor III

Dear Jay,

Please check below test environments.
1. CPU: RT1011
2. Compiler: MCUxpresso IDE

When I check compile option and compile output, XIP mode is set.
1. Compile option: "-DXIP_EXTERNAL_FLASH=1 -DXIP_BOOT_HEADER_ENABLE=1" is defined and is used.
2. From compile output, I can check below message.
BOARD_FLASH: 95840 B 16 MB 0.57%

And I used linkscripts to load some codes in ITCM but it is not related with this issue. (Without linkscripts there is same problem.)

Especially, when I download image to flash with MCUxpresso, there is no problem and downloaded image works well.
So, AXF file has no problem.

About error message with MCU Boot Utility, I can see when I press "Generate Unsigned Bootable Image" in "Image Generation Sequence" tab with on step mode.

Would you consider this problem again?

Thanks.

0 Kudos
190 Views
emdev
Contributor III

Dear Jay,

With debug build, I can see offline boot or stand alone operation.

But do you mean, is this not correct operation and do I need to compile with XIP builds or ram_0x1400?

Abut XIP builds or ram_0x1400, I'll check it and if there are any questions, I'll ask it again.

Thanks.

0 Kudos
142 Views
emdev
Contributor III

Dear Jay,

To convert axf to srec, NXP MCU Boot Utility uses iar_ewarm.

I think it is cause of problem but I don't know exact cause of problem.

I checked below link and can change axf to srec when I build images.

https://mcuoneclipse.com/2017/03/29/mcuxpresso-ide-s-record-intel-hex-and-binary-files/

With srec file which are made when image is built, there is no problem and it works well.

Thanks.

View solution in original post

0 Kudos