DeepViewRT SDK(RT1170+eIQ) is not compatible with standard SDK

cancel
Showing results for 
Search instead for 
Did you mean: 

DeepViewRT SDK(RT1170+eIQ) is not compatible with standard SDK

Jump to solution
257 Views
ZHOU_XIAO
NXP Employee
NXP Employee

Hello everyone, 

I  download the DeepViewRT SDK(RT1170+eIQ)  from this link (  https://www.nxp.com/design/software/development-software/eiq-ml-development-environment/eiq-inferenc...)  and I installed it by drag & drop the zip into "installed SDKs" , and I can run the model runner sample without problems

ZHOU_XIAO_0-1632703639771.png

 

And I also download and install  the standard sdk (2 .9.1   / 2.9.2/ 2.10.0)  from https://mcuxpresso.nxp.com/en/welcome

ZHOU_XIAO_1-1632703771289.png

ZHOU_XIAO_4-1632704110409.png

When I run the sample project  modelrunner (for example 2.9.2) , I find that error happens like follows

 
ZHOU_XIAO_5-1632704149660.png

If without the deepview SDK (SDK_2.x board_MIMXRT1170-EVK) , the sample project can build well.

if with the deepview SDK (SDK_2.x board_MIMXRT1170-EVK) ,the error will occur 

 

 Although I can fix it by rename the defined eiq interrupt....

Do we need to call uesrs' attention to this problem?

 

 

BR 

ZHOU

0 Kudos
1 Solution
191 Views
anthony_huereca
NXP Employee
NXP Employee

Hi Zhou,

  The DeepViewRT library included with the SDK is specific to the eIQ Portal version. So they need to be kept in sync. There's not a way to fix that other than using the latest SDK and latest version of eIQ Portal. I'll have the web team take those links down on the website to avoid future confusion. 

 

-Anthony 

View solution in original post

0 Kudos
5 Replies
214 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thanks for your reply.
1) DO you know the reason why the former version of standard SDK(2.9,1/2,9.2) can not work well with DeepViewRT SDK(RT1170+eIQ)?
-- Sorry, I don't know and you may need to contact the SDK team to explain the reason.

Have a great day.
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
248 Views
ZHOU_XIAO
NXP Employee
NXP Employee

Hello, jeremyzhou

 

Thanks for your confirmation. I also check that The new standard SDK(2.10.0) works well with the deepview SDK (SDK_2.x board_MItellMXRT1170-EVK).

 

I will tell customers  to update SDK to the new SDK(2.10.0). 

 

BR

ZHOU

0 Kudos
251 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thank you for your interest in NXP Semiconductor products and for the opportunity to serve you.
I try it just a moment ago, the issue won't raise when the SDK_2.x_MIMXRT1170-EVK is updated to 2.10.0.

jeremyzhou_0-1632712714968.png

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos
231 Views
ZHOU_XIAO
NXP Employee
NXP Employee

HI jeremezhou

DO you know the reason why the former version of standard SDK(2.9,1/2,9.2) can not work well with DeepViewRT SDK(RT1170+eIQ)?

in other word,Compared with former version ,what kind of modification of standard SDK(2.10.0) makes the error disappear?

 

BR

ZHOU

0 Kudos
192 Views
anthony_huereca
NXP Employee
NXP Employee

Hi Zhou,

  The DeepViewRT library included with the SDK is specific to the eIQ Portal version. So they need to be kept in sync. There's not a way to fix that other than using the latest SDK and latest version of eIQ Portal. I'll have the web team take those links down on the website to avoid future confusion. 

 

-Anthony 

View solution in original post

0 Kudos