Debugger can't connect to iMXRT1062 board after wrong FlexRAM configuration

cancel
Showing results for 
Search instead for 
Did you mean: 

Debugger can't connect to iMXRT1062 board after wrong FlexRAM configuration

Jump to solution
196 Views
Zu
Contributor II

Hi,

I have been trying to reconfigure the FlexRAM of iMXRT1062 to the following setting: DTCM 256kB; ITCM 64kB and OC 192kB. 
One thing I already know I probably did wrong is setting the CM7_CFGxTCMSZ fields of IOMUXC_GPR_GPR14 register to 0s before setting them to proper values (9 and 7).
Here is the code snippet from startup_mimxrt1062.cpp that I used:

Zu_2-1612256825703.png

I also:

- changed Memory map configuration in MCU Settings:

Zu_0-1612256287061.png

- corrected memory regions in board.c like so:

Zu_1-1612256318288.png

The program was uploaded and started but during startup ran into an error (at the address that looks like it is exactly the line that is setting IOMUXC_GPR_GPR14 fields to 0).

Since then I cannot connect to my board anymore, this is error info I see when trying to Debug:
(P&E Connection Assistant starts first but after failed retries, it shows this)

Error in services launch sequence.
PEmicro GDB Launch Failure: The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.

Also, when trying to Erase the Flash MCUXpresso just hangs up forever.

Is it possible that this incorrect configuration somehow bricked my board? 
Do you have any tips on how to recover from such situation?

Thanks in advance.
Regards,
Zuza C.

 

Tags (2)
0 Kudos
1 Solution
164 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thank you for your interest in NXP Semiconductor products and for the opportunity to serve you.
Firstly, you can try to follow the below steps to recover.
1) Setting the boot pins to Serial Downloader;
2) Connect the Debug tool;
3) Power up the board and click the debug icon to enter debug mode.
Secondly, I'd like to suggest you refer to the AN12077 to demonstrate the FlexRAM configuration.

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

View solution in original post

0 Kudos
2 Replies
149 Views
Zu
Contributor II

Hi Jeremy,

Thank you very much for your guidance!
After setting the boot pins to SerialDownloader mode I was able to establish a connection with my board again.

I did also manage to set up correct FlexRAM configuration after analysing the AN12077 document and also this post on NXP community: https://community.nxp.com/t5/i-MX-RT-Knowledge-Base/Reallocating-the-FlexRAM/ta-p/1117649 which described the implementation in a bit more details. 

Again thank you very much!
Greetings
Zuza

0 Kudos
165 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thank you for your interest in NXP Semiconductor products and for the opportunity to serve you.
Firstly, you can try to follow the below steps to recover.
1) Setting the boot pins to Serial Downloader;
2) Connect the Debug tool;
3) Power up the board and click the debug icon to enter debug mode.
Secondly, I'd like to suggest you refer to the AN12077 to demonstrate the FlexRAM configuration.

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

 

View solution in original post

0 Kudos