Debug configuration disabled

cancel
Showing results for 
Search instead for 
Did you mean: 

Debug configuration disabled

335 Views
meravs
Contributor I

Hi,

I'm unable to change Debugger configuration the (Attach only for example) stays the same no matter what i do.

Environment:

MCUXpresso 10.3.0.

Ubuntu 18.04.3 LTS

thank you.

0 Kudos
5 Replies

226 Views
meravs
Contributor I

I use the first option : Debug using LinkServer probes

0 Kudos

226 Views
jorge_a_vazquez
NXP Employee
NXP Employee

Hi Merav Strassberg

Could you share a screenshot of your screen when you tried to debug? Are you using the evaluation board or a custom board? (please verify the boot config pins).

Best regards

Jorge Alcala

0 Kudos

226 Views
meravs
Contributor I

Hi Jorge Alcala,

Yes, after erasing  the .launch configuration, and creating a new one the error persists.

I Also tried changing my MCUXpresso  version to 10.3.0 but it did not help .

Thank you.

0 Kudos

226 Views
jorge_a_vazquez
NXP Employee
NXP Employee

Hi Merav Strassberg

Can you please confirm that you don't have selected the "Attach to a running target using LinkServer" as the image below?

pastedImage_1.png

If you select this option, it is marked as default, so you have to select the debug option for the new .lauch configuration.

Hope this helps

Regards

0 Kudos

226 Views
jorge_a_vazquez
NXP Employee
NXP Employee

Hi Merav Strassberg

Did you change the debug configuration to make a flash process?

I would like to verify that the problem is related to the IDE and the launch config and not with the board or the project that you are using. Are you able to erase the .launch configuration debug? if you erase it and create a new one, the error persists?

Best regards

Jorge Alcala

0 Kudos