Cannot use ConfigTools for Pinmux in M4 Slave project for RT1170-EVK

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot use ConfigTools for Pinmux in M4 Slave project for RT1170-EVK

208 Views
D_Tram23
Contributor IV

I want to create a multi-core project in MCUXpresso, for the RT1170-EVK.

I want to use the M7 as the master and the M4 as the slave.

However, with this setup, I cannot use ConfigTools to generate the pinmux.c code. 

I can use ConfigTools as per usual, until I click on 'Update Code'.

At this point, I get a warning:

Pinmux_no_gen.jpg

When I press 'OK', the code in pinmux.c is not changed (as one would guess from the fact that it is greyed out). I cannot tick the box next to 'Pins'.

I assume it is related to the warning that I get in the ConfigTools view:

Pinmux_warning.jpg

I can do the Pinmux as per usual in the M7 Master project, but I need to configure some pins in the M4 Slave project.

Does anyone know how I can resolve this?

0 Kudos
8 Replies

184 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
To provide the fastest possible support, I'd highly recommend you to refer to the multicore_examples in the SDK library to create your own multicore demo project.
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

179 Views
D_Tram23
Contributor IV

@jeremyzhou 

Thank you for your response.

I have already referred to the SDK's multicore examples, but they have the same issue.

I am not sure how the examples have pinmux code in the M4 projects, unless that code was generated in another way and then copy-pasted into this file, which seems very counter-intuitive.

Could you please give me feedback on why one cannot use ConfigTools for M4 slave projects, and what can be done about it.

0 Kudos

171 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,

Thanks for your reply.
I've replicated the phenomenon and I think the mcuxpresso config tools doesn't support the feature now, in further, I'll report the finding in the next round of field trial.
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

168 Views
D_Tram23
Contributor IV

Hi @jeremyzhou 

Thank you for your response.

Could you please provide me with a suitable workaround while we wait for this feature to be supported?

Kind regards

0 Kudos

159 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thanks for your reply.
1) Could you please provide me with a suitable workaround while we wait for this feature to be supported?
-- Actually, it needs the developers to add or modify the code manually.
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

154 Views
D_Tram23
Contributor IV

@jeremyzhou 

I have 2 more questions:

1) Do you have an estimate for when this will be fixed?

2) Are there any other problems with the RT1170 SDK that you are aware of? I would like to know what they are so that I don't need to discover them myself.

Kind regards

0 Kudos

150 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thanks for your reply.
1) Do you have an estimate for when this will be fixed?
-- To be honest, I'm not assured.
2) Are there any other problems with the RT1170 SDK that you are aware of? I would like to know what they are so that I don't need to discover them myself.
-- No, I've not encountered any other bugs or problems with the SDK library for RT1170 until now.
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

146 Views
D_Tram23
Contributor IV

Hi @jeremyzhou 

Would it be possible for you to refer my last two questions to a colleague of yours who may know the answers?

My project is time-critical, so receiving this information as soon as possible would be extremely helpful!

Thank you for your assistance so far.

Kind regards

0 Kudos