Bus Error Generated by CPU

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bus Error Generated by CPU

Contributor III

I am using JTAG interface with Trace32 to load the program in IMXRT EVK board.

I tried to execute TFT on top of the working program. After a successful build I tried to flash the program and run but it wasnt running properly and gave the "Bus error generated by cpu" error. I dont know what changes caused this issue and I cant even program to previous working code now. At System.up in script itself giving the error.

Is there a way to factory reset the controller to go back to the initial state or something?

Please help me to solve this issue.

0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

Hi  @Ykciv 

  Please tell us which detail RT chip and board you are using?

  Do you test the SDK code, whether it works or not?

  Do you use the JTAG or the SWD? As the chip is using SWD interface in default.

  You may also mentione the EVK JTAG, please note, if you use the external debugger, you need to remove the jump which connect to the on board CMSIS DAP debugger, otherwise, it will have conflict, thanks. More details, please check your used board schematic.

Best Regards,


0 Kudos