wlan0 interface is not coming up for onboard wifi module with imx8 Nano evk


wlan0 interface is not coming up for onboard wifi module with imx8 Nano evk

Contributor II

Dear NXp,

As i am not able to bringing up the wifi module that is connected on imx8 Nano evk board, running below commands to bring up the interface, included wifi-tools to my .bblayer.

is there any other packages need to be add .bblayer to bring up this ?   

CMD outputs...

root@cu:~# ifconfig wlan0

ifconfig: wlan0: error fetching interface information: Device not found

root@cu:~# ifconfig wlan0 up
ifconfig: SIOCGIFFLAGS: No such device
Can not find device wlan0
0 件の賞賛
5 返答(返信)

Contributor III

How is this wifi controlled ? In general

1 - check the interface, generally sdio, by dmesg, check the driver is up and device is detected.

2 - check finally ethernet driver fro wifi is running/loaded (lsmod)

3 - check for firmware load error messages, as   dmesg | grep err  or "dmesg | grep firm" and messahes around that


0 件の賞賛

Contributor II

Hi everyone,

I'm having same issues in 2023  with the 8MNANOD4-EVK and the v6.1.1 Linux Distro version. I go through module activation with:


modprobe moal mod_para=nxp/wifi_mod_para.conf

After this, dmesg show:

Screenshot from 2023-06-19 17-00-56.png

Seems driver exists but its not  as verbose as i would like. Unfortunately, interface its not appearing

Screenshot from 2023-06-19 17-03-16.png

I tried to set the wifi network credentials in wpa_supplicant.conf and then updated with the command

wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf -D nl80211

But seems not to brings up the interface



I tried this process with full and multimedia image in the application images provided. I also try v5-15.71 and v5.10.52, same results as above.

Someone have any idea what could be happening? Thanks!

0 件の賞賛

Contributor V

Hi shilesh_babu,

You can check this post on the Murata forum: https://community.murata.com/s/question/0D55F000096S0K5SAK/imx-8m-nano-evk-wifi, which talks about a similar issue.

You can also refer to this Blog on the Murata forum: https://community.murata.com/s/article/Drill-down-Steps-to-Bring-up-1MW-on-i-MX8M-Mini-EVK. This describes the process of bring up the on-board Wi-Fi module on i.MX 8MMini. The procedure would be similar for 8MNano.

Best regards

0 件の賞賛

Contributor II

Anyone have any update on the above question?

0 件の賞賛

NXP TechSupport
NXP TechSupport

refer to the latest yocto release note, which Supports Murata 1MW (CYW43455) Wi-Fi/Bluetooth on i.MX 8M Mini and i.MX 8M Nano. so what WIFI module do you ues? and what bsp do you use

0 件の賞賛