we can't build valgrind-3.3.1 for i.mx28 on ltib platform, because have no the patchs.

cancel
Showing results for 
Search instead for 
Did you mean: 

we can't build valgrind-3.3.1 for i.mx28 on ltib platform, because have no the patchs.

408 Views
luoqiaofa
Contributor II

we downloaded  valgrind-3.3.1, but we cant get the pathchs as follows

Patch1          :valgrind-3.3.1-8xx.patch

Patch2          : valgrind-3.3.1-softfloat-02.patch


the valgrind-3.3.1  we downloaded is not from the official web,   maybe can't match with the patchs above.

can you give it too?

Labels (1)
Tags (1)
0 Kudos
1 Reply

143 Views
FernandoGinezd1
Contributor II

Hi!

In spite of seeing that this questions was made at long time ago, i'd like to register the solution i've found for log purposes.

After spending some hours trying to build LTIB's valgrind specified version, I've found this post (How to build Valgrind 3.6.0 for Beagleboard-xM on Ubuntu | Embedded HOWTOs) which helped me to build valgrind's latest version (3.10.1).

You just have to follow the instructions which consists on the right './configure' parameters for your platform. In my environment I've used (iMX53-QSB):

./configure -prefix=/opt/valgrind -host=armv7-none-linux-gnueabi -target=arm-none-linux-gnueabi -build=i386-ubuntu-linux

And then:

make

And finally:

make install

After this last step, all necessary files were copied to $prefix directory on my build system.

A very important information is that you must copy and run valgrind from $prefix directory into your board, because the path is hardcoded into valgrind's binaries.

I wish you all success.

Best regards,

Fernando Ginez da Silva

0 Kudos