wayland image with QT5 fails to build on Yocto Rocko for i.mx8m

cancel
Showing results for 
Search instead for 
Did you mean: 

wayland image with QT5 fails to build on Yocto Rocko for i.mx8m

Jump to solution
3,056 Views
richard_hu
Contributor V

Hello, Sir:

I follow the step in "i.MX_Yocto_Project_User's_Guide" to build wayland image with QT5(not xwayland) for  i.MX8 MQuad EVK and it always fails on building QT example "quickcontrols/controls".

The instructions i give are as follows:

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-rocko -m imx-4.9.88-2.0.0_ga.xml

repo sync -j8

DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source fsl-setup-release.sh -b build-wayland

bitbake fsl-image-qt5-validation-imx

The error message is as follows:

| ERROR: oe_runmake failed
| WARNING: /home/pico/workspace2/yocto/yocto_tn_rocko/nxp/build-wayland/tmp/work/aarch64-mx8mq-poky-linux/qtbase/5.9.4+gitAUTOINC+0d9208cecb-r0/temp/run.do_compile.19906:1 exit 1 from 'exit 1'
| ERROR: Function failed: do_compile (log file is located at /home/pico/workspace2/yocto/yocto_tn_rocko/nxp/build-wayland/tmp/work/aarch64-mx8mq-poky-linux/qtbase/5.9.4+gitAUTOINC+0d9208cecb-r0/temp/log.do_compile.19906)
ERROR: Task (/home/pico/workspace2/yocto/yocto_tn_rocko/nxp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 2654 tasks of which 0 didn't need to be rerun and 2 failed.

Summary: 2 tasks failed:
  /home/pico/workspace2/yocto/yocto_tn_rocko/nxp/sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-graphics/opencv/opencv_3.4.bb:do_compile
  /home/pico/workspace2/yocto/yocto_tn_rocko/nxp/sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile
Summary: There were 8 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

I upload the complete error log as an attachment.

I don't encounter this problem when i build the xwayland image. It only happens on wayland.

1 Solution
1,577 Views
richard_hu
Contributor V

Hello, Gusarambula:

After i "repo sync", and run the build again. This issue is gone.

Now, it can produce "fsl-image-qt5-validation" image with wayland backend.

Thank for your help~!!!

BR,

Richard

View solution in original post

3 Replies
1,298 Views
brsmnc
Contributor II

Hello, I have the same issue.

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-zeus -m imx-5.4.47-2.2.0.xml
DISTRO=fsl-imx-wayland MACHINE=imx8mqevk source imx-setup-release.sh -b imxImageFull
bitbake imx-image-full

gives this error and exit.

...sources/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_compile  failed with exit code '1'

But I can build imx-image-multimedia successfully. I also tried bitbake -c clean but nothing changed. What sould I do?

0 Kudos
1,577 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Richard Hu,

Are you still having problems when baking the Qt5 image? I will try to reproduce the problem. It is odd that the xwayland is working correctly and the wayland distro is not, considering that xwayland has many more dependencies.

I’ll let you know if I find something.

Regards,

0 Kudos
1,578 Views
richard_hu
Contributor V

Hello, Gusarambula:

After i "repo sync", and run the build again. This issue is gone.

Now, it can produce "fsl-image-qt5-validation" image with wayland backend.

Thank for your help~!!!

BR,

Richard

View solution in original post