vpuenc_h264 (imx-gst1.0-plugin_4.3.4) compatibility with Apple homekit IPCamera accessory

cancel
Showing results for 
Search instead for 
Did you mean: 

vpuenc_h264 (imx-gst1.0-plugin_4.3.4) compatibility with Apple homekit IPCamera accessory

565 Views
angeloaresi
Contributor I

Hi,

we are developing an homekit IPcamera accessory using an iMX6Solo cpu.

the pipeline is

imxv4l2videosrc ---> imxipuimagetransform ---> vpuenc_h264  ---> Apple RTP API

All was working fine until we used Yocto FIDO with old fsl plugins (vpuenc).

Now, after updating Yocto to Rocko and fsl plugins to 4.3.4, there is no way to get the video decoding start on iOS side.

What have been changed on vpu encoding ?

Something related to SPS PPS AUD order ?

Thanks in advance,

Angelo

Tags (2)
0 Kudos
1 Reply

339 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Angelo

seems L4.9.51 used in the case as "4.3.4" plugin number is described in Release Notes

section Mulimedia in documentation package for that release

https://www.nxp.com/webapp/Download?colCode=L4.9.51_8MQ_GA_LINUX_DOCS&Parent_nodeId=1337699481071706... 

However this release was not tested with i.MX6S, for i.MX6S recommended to use

Linux 4.9.88_2.0.0 BSP & Multimedia Codecs ("4.3.5" plugin) described on

i.MX Software|NXP 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos