unable to upload to NXP 1170 eval board

cancel
Showing results for 
Search instead for 
Did you mean: 

unable to upload to NXP 1170 eval board

Jump to solution
392 Views
tomdunigan
Contributor II

I managed to brick my 1170 eval board with bad setting for GPT2 mux in clock_config.c.  I am unable to upload a new program.  Is there a way to erase the QSPI flash,  or some other magic to get around the killer program on the board ?  I have developed many working programs for the 1170, but I am not proficient in the use of the IDE.

I'm on ubuntu linux with MCUXpresso_11.3.1_5262 using USB as debug console (/dev/ttyACM0).    "debug"  fails for cm7 blinky program, with popups saying things like

"O2: failed on connect"

"Failed to execute MI command"

"Error in final launch sequence"

Labels (1)
0 Kudos
1 Solution
383 Views
tomdunigan
Contributor II

OK, reviewing my NXP 1060 notes, I had the same problem with 1060 eval board.  I used GUI Flash Tool to erase flash. 

After a couple of tries with SW2 settings, this worked:

1) power off eval board

2) set SW2-7 to ON

3) power up and from IDE run GUI Flash Tool and select "erase flash" tab, and RUN (took about 25 seconds to erase flash)

4) power down eval board and set SW2-7 back to OFF

5) power up eval board and upload a working program  

View solution in original post

0 Kudos
1 Reply
384 Views
tomdunigan
Contributor II

OK, reviewing my NXP 1060 notes, I had the same problem with 1060 eval board.  I used GUI Flash Tool to erase flash. 

After a couple of tries with SW2 settings, this worked:

1) power off eval board

2) set SW2-7 to ON

3) power up and from IDE run GUI Flash Tool and select "erase flash" tab, and RUN (took about 25 seconds to erase flash)

4) power down eval board and set SW2-7 back to OFF

5) power up eval board and upload a working program  

0 Kudos