uart7 not working in imx7d

cancel
Showing results for 
Search instead for 
Did you mean: 

uart7 not working in imx7d

239 Views
vijayhs
Contributor I

Hi,

I have a custom board which is based on imx7dsabresd. I am using "linux-imx-4.1.15". I am trying to bring up uart7 but no success. I don't see any data coming out on uart7_Tx.

UART7_RX and UART7_TX are on the pads EPDC_DATA12 and EPDC_DATA13 respectively. I have attached the schematics for the same. The dts changes are as below

In the file "imx7d.dtsi"

            uart7: serial@30a90000 {
                compatible = "fsl,imx7d-uart",
                         "fsl,imx6q-uart", "fsl,imx21-uart";
                reg = <0x30a90000 0x10000>;
                interrupts = <GIC_SPI 126 IRQ_TYPE_LEVEL_HIGH>;
                clocks = <&clks IMX7D_UART7_ROOT_CLK>,
                    <&clks IMX7D_UART7_ROOT_CLK>;
                clock-names = "ipg", "per";
                dmas = <&sdma 34 4 0>, <&sdma 35 4 0>;
                dma-names = "rx", "tx";
                status = "okay";
            };

In the file "imx7d-sdb.dts"

&uart7 {
    pinctrl-names = "default";
    pinctrl-0 = <&pinctrl_uart7>;
    assigned-clocks = <&clks IMX7D_UART7_ROOT_SRC>;
    assigned-clock-parents = <&clks IMX7D_OSC_24M_CLK>;
    status = "okay";
};

&iomuxc {

         ...

         ...

         imx7d-sdb

         {

               ...

               ...

              pinctrl_uart7: uart7grp {
                     fsl,pins = <
                                  MX7D_PAD_EPDC_DATA12__UART7_DCE_RX 0x79
                                  MX7D_PAD_EPDC_DATA13__UART7_DCE_TX 0x79
                    >;
              };

               ...

               ...

          }

         ...

         ...

}

Kindly, help me to solve this issue.

Thanks & Regards

Vijay H.S 

Labels (1)
0 Kudos
3 Replies

42 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Vijay

one can try to change "assigned-clock-parents" as in uart6 in dts example

imx7d-sdb.dts\dts\boot\arm\arch - linux-imx - i.MX Linux kernel 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

42 Views
vijayhs
Contributor I

Hi Igor,

Thanks for the reply.

I tried with

assigned-clock-parents = <&clks IMX7D_PLL_SYS_MAIN_240M_CLK>;

which is same as uart6, but still no success.

Regards

Vijay H.S

0 Kudos

42 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Vijay

one can try to debug it: check if clocks are enabled in CCM_CCGR154

(uart7), write some data to UARTx_UTXD, check signal with oscilloscope.

Debugging Linux Kernel over JTAG with J-Link 

Best regards
igor

0 Kudos