startx fail on imx8mq-evk

cancel
Showing results for 
Search instead for 
Did you mean: 

startx fail on imx8mq-evk

286 Views
Contributor III

I run startx on iMX8MQ-evk and get error 'no screens found (EE)'. What does it happen ? How do I fix it ?

Labels (2)
14 Replies

4 Views
Contributor IV

hi I have the some issue. I use maaxboard from iMX8MQ-evk, any help ?

the screen display for terminal.  I want to run chromium,

1, first I I  run X

faal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.

---------------

/var/log/Xorg.0.log

vi /var/log/Xorg.0.log

[ 1592.731] (II) LoadModule: "glx"
[ 1592.731] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 1592.734] (II) Module glx: vendor="X.Org Foundation"
[ 1592.734] compiled for 1.19.6, module version = 1.0.0
[ 1592.734] ABI class: X.Org Server Extension, version 10.0
[ 1592.734] (II) LoadModule: "vivante"
[ 1592.734] (WW) Warning, couldn't open module vivante
[ 1592.734] (II) UnloadModule: "vivante"
[ 1592.734] (II) Unloading vivante
[ 1592.734] (EE) Failed to load module "vivante" (module does not exist, 0)
[ 1592.734] (EE) No drivers available.
[ 1592.734] (EE)
Fatal server error:
[ 1592.734] (EE) no screens found(EE)
[ 1592.734] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 1592.734] (EE) Please also check the log file at "/var/log/Xorg.0.log" for add
ditional information.
[ 1592.734] (EE)
[ 1592.735] (EE) Server terminated with error (1). Closing log file.

2 then I run 

export DISPLAY=:0;

chromium --no-sandbox

(chromium:3799): Gtk-WARNING **: cannot open display: :0

0 Kudos

4 Views
Contributor III

My experience is that the bootloader setting fail on bootargs. You have to set the bootargs 

video=HDMI-A-1:1920x1080-32@60. The key is HDMI-A-1 not HDMIA-1. I got it work with this change.

4 Views
Contributor IV

NO, Not work for me.

I follow the guide, I can not find the chromium and startx or X binary code in image  too. 

I posted my issue here:

https://community.nxp.com/message/1279209 

0 Kudos

4 Views
Contributor III

I just used Yocto to get bootloader source code, video firmware binary file & Linux kernel source code. I built bootloader &  kernel independent. I installed Debian Stretch root file system on SD card. Use debain to install xorg, xserver-xorg, gdm3. And disable GPU & VPU in kernel device tree.

0 Kudos

4 Views
Contributor IV

I need optee support. I am not sure how to install optee in Debian Stretch root file system , I did not do before.  anyway I will try to using Debian Stretch root file system .

I want to know where is video firmware binary file in yocto? do I need change it?

Thank you.

0 Kudos

4 Views
Contributor III

I installed optee too. The optee is independent with Debian. I also enable secured boot following i.MX8 user guide. The video firmware binary file didn't need to be changed. You can directly to use it. The video firmware signed_hdmi_imx8m.bin got from build/tmp/deploy/images/imx8mqevk directory in Yocto.

0 Kudos

4 Views
Contributor IV

thank you.

Maybe I am not not enable GPU driver. I compared the shipment yocto kernel config and my yocto config (should be imx8mq-evk default config).

I am trying it

ls /dev/galcore
ls: cannot access '/dev/galcore': No such file or directory

0 Kudos

4 Views
Contributor IV

Thank you,

let me try

0 Kudos

4 Views
NXP TechSupport
NXP TechSupport

Which screen are you use?

0 Kudos

4 Views
Contributor III

I use Asus HDMI 1080P. It is a very public screen. The text mode login terminal is run good. I test utility fbtest also good. Just Xwindows is fail !

0 Kudos

4 Views
NXP TechSupport
NXP TechSupport

Hi Victor,

Are you using the demo images in our website? In our default BSP only the fsl-imx-xwayland - Wayland graphics and X11 are supported.

Have a nice day

Rita

0 Kudos

4 Views
Contributor III

I rebuild fsl-image-x11 from Yocto project which is fail. 

0 Kudos

4 Views
NXP TechSupport
NXP TechSupport

Build the fsl-image-x11 steps you can refer to i.MX_Yocto_Project_User's_Guide.

0 Kudos

4 Views
Contributor III

Of course. I follow the user's guide to rebuild. And no error is in rebuilding. It is rebuilt very smoothly. The rebuilt images is run good. Just Xwindows is fail ! 

0 Kudos