sabrelite imx6 lcd not displaying correct colors

cancel
Showing results for 
Search instead for 
Did you mean: 

sabrelite imx6 lcd not displaying correct colors

Jump to solution
3,307 Views
varsmolta
Contributor V

Attached is a pic and a video of a 2.4 inch lcd that I am trying to use in RGB 16 bit mode connected to a sabrelite imx6. The colors don't come out right. I have triple checked the pinouts. There is an abundance of blues. When I try to play video, it looks bluish and pixelated. The video attached is bugbuckbunny. Has anyone encountered this? I've tried using fbset to change the bpp to 18 and test it as well (making the corresponding changes to the lcd pinouts for 18-bit mode) but fbset does not seem to set the bpp. It is always hard-coded to 16. FYI, i've used a beaglbone to test that the lcd is not a defect, so the problem is real. any input is appreciated. Thankslcd.jpg

1 Solution
791 Views
varsmolta
Contributor V

so I got this working. my pin mappings were wrong. they should be the following:

In 18 bit mode (note: kernel command line should be something on the order of video=mxcfb0:dev=lcd,800x480M@55,if=RGB666):

DISP0_DAT0:DISP0_DAT5 - B0-B5

DISP0_DAT6:DISP0_DAT11 - G0-G5

DISP0_DAT12:DISP0_DAT17 - R0-R5

In 16 bit mode:

DISP0_DAT0:DISP0_DAT4 - B0-B4

DISP0_DAT5:DISP0_DAT10 - G0-G5

DISP0_DAT11:DISP0_DAT15 - R0-R4

In the IMX6 reference manual, there is mention that this mapping can be changed in software (see sec 37.4.7.5.1 Bus Mapping Unit) but I haven't given this a try since I didn't need to.

View solution in original post

3 Replies
791 Views
ricardo_ioct
Contributor III

Hello, varsmolta,

I'm interfacing an i.MX53 module with a LCD Panel 240x320 too. What is the Part Number of this display? I',m very interested.

Att.,

0 Kudos
791 Views
varsmolta
Contributor V

here is another clearer pic of the display on the lcd and the original image. Ignore the horizontal inverted image. This image on the lcd was displayed by writing to the fb directly: cat image.raw > /dev/fb0

0628130234.jpgdest.png

0 Kudos
792 Views
varsmolta
Contributor V

so I got this working. my pin mappings were wrong. they should be the following:

In 18 bit mode (note: kernel command line should be something on the order of video=mxcfb0:dev=lcd,800x480M@55,if=RGB666):

DISP0_DAT0:DISP0_DAT5 - B0-B5

DISP0_DAT6:DISP0_DAT11 - G0-G5

DISP0_DAT12:DISP0_DAT17 - R0-R5

In 16 bit mode:

DISP0_DAT0:DISP0_DAT4 - B0-B4

DISP0_DAT5:DISP0_DAT10 - G0-G5

DISP0_DAT11:DISP0_DAT15 - R0-R4

In the IMX6 reference manual, there is mention that this mapping can be changed in software (see sec 37.4.7.5.1 Bus Mapping Unit) but I haven't given this a try since I didn't need to.