run standalone bare-metal application on u-boot on the iMX6

cancel
Showing results for 
Search instead for 
Did you mean: 

run standalone bare-metal application on u-boot on the iMX6

1,590 Views
andreacolomba
Contributor II

I am trying to run a bare-metal application written for an imx6dq based board using iMX6 bare-metal sdk using u-boot.

After compiling the application I put it on SD card and run the following commands from u-boot.

> fatload mmc 1 0x10000000 demo.bin'

> go 0x100006d0

> ## Starting application at 0x100006D0 ...

The result is that everything hangs..

By looking at the .map file the memory configuration is attached in this post.

Instead of booting directly from the standalone app I want to use u-boot to do it because the board comes with u-boot on emmc flash.

As I said before the standalone program is compiled using iMX6 sdk, so it is self-contained and doesn't call any of the u-boot functions. Also by loooking at the elf file the entry point address is 0x100006d0 so if I jump to that address it should work, but it hangs.

I've already looked at the post How do I use uboot to run stand alone applications that I compile with ARM DS-5 on the i.MX6 ?  but didn't find anything useful.

Can you help me? What should I do in order to run standalone application compiled with sdk using u-boot?

Original Attachment has been moved to: demo.map.zip

Labels (1)
0 Kudos
2 Replies

371 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Andrea

one can check Figure 8-21 Image Vector Table i.MX6Q  RM

http://cache.freescale.com/files/32bit/doc/ref_manual/IMX6DQRM.pdf 

so if in image boot_data      0x0000000010000420, one can load image and try: go 0x10000420.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

371 Views
fabianoferronat
Contributor I

hi,

I'm using toradex Apalis imx6 and I'm having the same problem.

Can you detail your answer?

Where did you found this number ? 0x0000000010000420

Which is the entry point address? And the load address? And the GO address?

thanks

0 Kudos