requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_MediaLib-dev? [file-rdeps]

cancel
Showing results for 
Search instead for 
Did you mean: 

requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_MediaLib-dev? [file-rdeps]

7,922 Views
ponguru_s
Contributor III

ERROR: MediaLib-0.1-r0 do_package_qa: QA Issue: -dev package contains non-symlink .so: MediaLib-dev path 'work/cortexa9hf-neon-poky-linux-gnueabi/MediaLib/0.1-r0/packages-split/MediaLib-dev/usr/lib/libMediaLibrary.so' [dev-elf]
WARNING: MediaLib-0.1-r0 do_package_qa: QA Issue: /usr/lib/libMediaLibrary.so contained in package MediaLib-dev requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_MediaLib-dev? [file-rdeps]
ERROR: MediaLib-0.1-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
ERROR: MediaLib-0.1-r0 do_package_qa: Function failed: do_package_qa
ERROR: Logfile of failure stored in: /home/user1/AGL_BUILD/fsl-arm-yocto-bsp/<my_build_dir>/tmp/work/cortexa9hf-neon-poky-linux-gnueabi/MediaLib/0.1-r0/temp/log.do_package_qa.24842
ERROR: Task 9 (/home/user1/AGL_BUILD/fsl-arm-yocto-bsp/sources/meta-sample/recipes-mw/medialib/MediaLib_0.1.bb, do_package_qa) failed with exit code '1'
NOTE: Tasks Summary: Attempted 364 tasks of which 363 didn't need to be rerun and 1 failed.

MediaLib is the dynamic shared object created based upon my own requirements.

This has been the error I'm facing and unable to get any references to resolve this issue. Please help me with this.

Labels (2)
0 Kudos
5 Replies

864 Views
el14
Contributor II

Renaming the bb file without caps ,underscore etc have solved the same issue for me!

266 Views
Jackie_Zhou
Contributor I
Geting rid of all caps helps slove the problems, Thanks!
0 Kudos

3,399 Views
tedwu
Contributor I

I also have the same problem.  It shows as follows.

WARNING: recordingAgent-3-r0 do_package_qa: QA Issue: /usr/bin/recordingAgent contained in package recordingAgent requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_recordingAgent? [file-rdeps]

But the library of libc.so.6 is at the folder of tmp/sysroots/imx7dsabresd/lib.

Can anyone tell me how to solve it?

0 Kudos

3,399 Views
ponguru_s
Contributor III

SUMMARY = "Media Library"
SECTION = "examples"
LICENSE = "MIT"

BB_STRICT_CHECKSUM = "0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"

SRC_URI = "your_source_files"

S = "${WORKDIR}"
VER = "1"
HASHSTYLE = "gnu"

do_compile () {
${CC} -fPIC -shared -Wl,--hash-style=${HASHSTYLE} -o libMediaLibrary.so.${VER} -Wl,-soname,libMediaLibrary.so.${VER} source_files 
}

do_install() {
install -Dm755 ${B}/libMediaLibrary.so.${VER} ${D}${libdir}/libMediaLibrary.so.${VER}
ln -sf libMediaLibrary.so.${VER} ${D}${libdir}/libMediaLibrary.so
}

You can compare your code with the code mentioned above in the respective recipe file and try running the bitbake. The bold-italic terms are to be modified according to your library and source files.

The error is because no soft link is available.

Please let me know the status. :smileyhappy:

3,399 Views
joanxie
NXP TechSupport
NXP TechSupport

maybe you can downlaod the source package,

<RPM resource libc.so.6 >.

0 Kudos