"max11801_ts 1-0048: FIFO_RD_AUX_MSB read fails" IMX6Q

cancel
Showing results for 
Search instead for 
Did you mean: 

"max11801_ts 1-0048: FIFO_RD_AUX_MSB read fails" IMX6Q

Jump to solution
1,090 Views
Contributor II

Hello all.

I am working on an imx6qsabresd board. While I am booting the device,  the console adding the "max11801_ts 1-0048: FIFO_RD_AUX_MSB read fails" message continuously. It is annoying and hard to use the console because of this error. I did a research about this error. The touchscreen driver which is controlled by using I2C is causing this error. Hence, I want to disable the I2C in device tree to avoid this error. (I am open to try your own solutions, I have doubts about this solution) However, I couldn't accomplish that.  If you help me, I will be more than happy.

Many thanks. 

Tags (2)
0 Kudos
1 Solution
83 Views
Contributor II

I modified the linux kernel defconfig to avoid the error. I disabled the touchscreen and the error is gone.

Thanks all.

View solution in original post

0 Kudos
3 Replies
83 Views
NXP TechSupport
NXP TechSupport

Hi Giray

one can check signal with oscilloscope and tweak pull resistor value

if necessary for improving waveforms. Also one can try to decrease i2c frequency.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

83 Views
Contributor II

Hi Igor.

Is there a way to avoid this error without manipulating the hardware? I do not want to solve this error. I just do not want to see it on the console continuously popping out. I thought, I could comment the line which causes error message on the console in the source code. Do you think this is a good solution?

Many thanks.

0 Kudos
84 Views
Contributor II

I modified the linux kernel defconfig to avoid the error. I disabled the touchscreen and the error is gone.

Thanks all.

View solution in original post

0 Kudos