"No GSettings schemes are installed on the system" error when running gnome-bluetooth on i.MX6Q SABRE SD

cancel
Showing results for 
Search instead for 
Did you mean: 

"No GSettings schemes are installed on the system" error when running gnome-bluetooth on i.MX6Q SABRE SD

675 Views
Contributor III

Hello everyone,

I bitbaked the recipe "gnome-bluetooth", which produced four binaries, namely bluetooth-applet, bluetooth-properties, bluetooth-wizard, and bluetooth-sendto. I transferred the contents of the gnome-bluetooth's "image" folder into their corresponding folder hierarchy in the target filesystem, so that the shared libraries and other related files are in their proper folder in the target. Now when I tried running the "bluetooth-applet" binary, the following error appeared:

"GLib-GIO-ERROR: No GSettings schemes are installed on the system. Trace/breakpoint trap"

The same error also appeared when I tried to run bluetooth-properties. Strangely enough, the remaining two binaries bluetooth-sendto and bluetooth-wizard can start. I was wondering if anyone has used the gnome-bluetooth manager for their board, and if anyone also encountered the same error. I know I did a mistake somewhere in the process, but I would appreciate if anyone can point me in the right direction. BTW,  my host platform is an x86 64 bit PC with Ubuntu 12.04 LTS.

Thank you!

Labels (3)
3 Replies

60 Views
Contributor III

Hello,

I want to update this thread since I managed to make some progress, but now I am encountering a different problem. Here's what I did:

1) I added gnome-bluetooth and gsettings-desktop-schemas to the fsl-image-x11 recipe and bitbaked fsl-image-x11

2) After SABRE booted up I entered "export DISPLAY=:0.0"

3) I tried to start the "bluetooth-applet", but after entering the command bluetooth-applet, I was greeted by this error: "org.gnome.Bluetooth schema not installed". So I searched around the target filesystem and found out .xml files including the one for gnome-bluetooth, and learned that I needed to install these .xml files from this link: https://developer.gnome.org/gio/stable/ch32s06.html. Basically I needed to run this command "glib-compile-schemas </usr/share/path to xml schemas>".

4) After compiling the GSettings schema for gnome-bluetooth, I tried running "bluetooth-applet" from the command line and now this error shows up: "GLib-GIO Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications." Nothing shows up but whenever I run the "configure bluetooth" app on the Yocto Project desktop, a window appears successfully. I can also run the other three binaries from the command line.

Whenever I reboot the board I need to run steps 2 and 3 first before I can run the gnome-bluetooth binaries. I'll post updates once I make progress on this problem.

60 Views
NXP TechSupport
NXP TechSupport

Thanks for posting your progress! There is indeed nor much information on this feature. Even the Gnome Help is a bit short on documentation on their Schemas.

Please keep us posted on your progress!

60 Views
Contributor III

Thanks gusarambula,

I got rid of the "GSettings memory backend" message by adding the package "dconf" to the fsl-image-x11 recipe. From my understanding GSettings and Dconf work together: Gconf, Dconf, Gsettings and the relationship between them - Ask Ubuntu. Now I only need to find out how to install the .xml file automatically at startup, without typing "glib-compile-schemas </path to xml schemas>" always. Also, I now need to test if gnome-bluetooth can actually pair devices via Bluetooth, which is an altogether different problem :smileyhappy:

0 Kudos