qtwebengine build error in Yocto for imx6q project

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

qtwebengine build error in Yocto for imx6q project

2,871 Views
sergepayre
Contributor III

Hi,

I'm trying to add qtwebengine (part of 5.14.2 Qt release ) into my board image but I have the following error during the compile

[16223/16422] CXX v8_snapshot/obj/v8/src/inspector/inspector/inspector_jumbo_5.o
[16224/16422] CXX v8_snapshot/obj/v8/src/inspector/inspector/inspector_jumbo_4.o
[16225/16422] STAMP v8_snapshot/obj/v8/src/inspector/inspector.stamp
[16226/16422] STAMP v8_snapshot/obj/v8/v8_base_without_compiler.stamp
[16227/16422] LINK v8_snapshot/mksnapshot
[16228/16422] ACTION //v8:run_mksnapshot_default(/home/dev/pr3366-firmware-apm3plus/tmp_yocto/build/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.14.2+gitAUTOINC+35aa6c30f0_6c9be50c2d-r0/build/src/toolchain:target)
FAILED: gen/v8/embedded.S gen/v8/snapshot.cc
/home/dev/pr3366-firmware-apm3plus/tmp_yocto/build/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.14.2+gitAUTOINC+35aa6c30f0_6c9be50c2d-r0/recipe-sysroot-native/usr/bin/python-native/python2 ../../../../git/src/3rdparty/chromium/v8/tools/run.py ./v8_snapshot/mksnapshot --turbo_instruction_scheduling --target_os=linux --target_arch=arm --embedded_src gen/v8/embedded.S --embedded_variant Default --random-seed 314159265 --startup_src gen/v8/snapshot.cc --no-native-code-counters


#
# Fatal error in , line 0
# unreachable code
#
#
#
#FailureMessage Object: 0xf6fc7fe4
ninja: build stopped: subcommand failed.
make[3]: *** [Makefile.gn_run:363: run_ninja] Error 1

I'm working on Dunfell (linux Long Term Support until Apr. 2024)

 

Does anybody have a solution?

Labels (2)
0 Kudos
Reply
4 Replies

2,851 Views
sergepayre
Contributor III

Hi,

Thanks for your respone

1) Which version of qt is supported by NXP ?

2) I know the cpu problem. I had it when I wanted to compile nodejs and I solved it by putting the following parameters in my local.conf

# Default to setting automatically based on cpu count
BB_NUMBER_THREADS = "4"

# Default to setting automatically based on cpu count
PARALLEL_MAKE = "-j 4"

for imformation, I have 12 CPU and 16 Go of RAM on my host (64 bits)

3) Today I have continuous to investigate and I get the following error when I launch Makefile in shell session open with the commands 'bitbake qtwebengine -c devshell'. and 'cd ../build'.

ninja: Entering directory `/home/dev/pr3366-firmware-apm3plus/tmp_yocto/build/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.14.2+gitAUTOINC+35aa6c30f0_6c9be50c2d-r0/build/src/core/release'
[1/195] ACTION //v8:run_mksnapshot_default(/home/dev/pr3366-firmware-apm3plus/tmp_yocto/build/tmp/work/c...dl-poky-linux-gnueabi/qtwebengine/5.14.2+gitAUTOINC+35aa6c30f0_6c9be50c2d-r0/build/src/toolchain:target)
FAILED: gen/v8/embedded.S gen/v8/snapshot.cc
/home/dev/pr3366-firmware-apm3plus/tmp_yocto/build/tmp/work/cortexa9t2hf-neon-mx6qdl-poky-linux-gnueabi/qtwebengine/5.14.2+gitAUTOINC+35aa6c30f0_6c9be50c2d-r0/recipe-sysroot-native/usr/bin/python-native/python2 ../../../../git/src/3rdparty/chromium/v8/tools/run.py ./v8_snapshot/mksnapshot --turbo_instruction_scheduling --target_os=linux --target_arch=arm --embedded_src gen/v8/embedded.S --embedded_variant Default --random-seed 314159265 --startup_src gen/v8/snapshot.cc --no-native-code-counters
ERROR: ld.so: object 'libpseudo.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.


#
# Fatal error in , line 0
# unreachable code
#
#
#
#FailureMessage Object: 0xf7022fe4
ninja: build stopped: subcommand failed.

 

Regards

 

0 Kudos
Reply

2,855 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello sergepayre,

You are using a nonsupported qt version yet, but I guess your issue is that you are using a lot of threads, try to decrease number of threads used for the parallel build.

Regards

0 Kudos
Reply

2,819 Views
sergepayre
Contributor III

Hi,

I've still have the problem when I'm trying to build qtwebengine on virtual machine based on unbuntu 20.04 x64

and I have no problem on virtual Machine ubuntu 16.04 i386

regards

0 Kudos
Reply

2,793 Views
sergepayre
Contributor III

Hi,

I've found!

To comp le QtWebEngine on a 64-bit architecture you just need to create an append on the QtWebEngine recipe (qtwebengine_%.bbappend) with the following information:

BUILD_CC_ARCH += "-m32"
EXTRA_QMAKEVARS_CONFIGURE += "-no-webengine-v8-snapshot"

If you don't use v8-snapshot of course

No go to test